Creating & deleting a bookmark consistently generates an error

To replicate…

  1. Create an untimed bookmark on a post on a topic.
  2. Refresh the page and delete the bookmark

I’m using the Discourse official hosting.

i tried this on my test discourse, but i cant repo this.

Do you have any theme components installed ?

Yes, I do.

I run two different hosted sites and it happens on both of them. With the exception of “discourse gifs” (which was only installed a few days ago - I’m pretty sure the error was happening before that), theme components are different on both sites.

can you list them so that i can install them as well and then try to repo it

Site 1 theme/components:



Site 2 theme/components:



I’ve tried it in my test site, my live site, a site I’m on that’s discourse hosted, and here on meta and I can’t replicate it.

Are there are other steps I may be missing?

Here’s what I’m doing…


when last did you upgrade discourse, the theme & components ?

I’ve got it. You have to bookmark the topic, not a post. :+1:

Discourse is hosted so upgrades are automatic.

Themes/components are up to date. Site 2 is a new one - only started a couple of weeks ago - and everything started off up to date.

you can bookmark a post.

Not if you want to replicate the error

Oh, yeah. I just tried it on a post (not a topic) and it doesn’t cause the error.

1 Like

I can reproduce it on my test site, my live site, and the Discourse hosted site I’m on, but not here on meta.

I’m not on the latest, latest update - so it could be that this is already fixed. I’ll update my test site and try again.

Steps to reproduce:

  • bookmark a topic (untimed)
  • refresh page
  • delete bookmark

Edit: Updating to 28b00dc6fc has cleared this up on my test site. :+1:


Oh I think this was fixed yesterday by @martin . Thanks for confirming @JammyDodger and bringing this up!