CTRL-C triggers "Create topic" shortcut in Firefox Nightly


(Jonathon) #1

Description

Starting over the last few days, Discourse will open the New Topic composer when the user presses CTRL+C.

Pressing only C also triggers the New Topic composer as expected.

Related change?

On first glance it appears to be related to:

though that’s supposed to enable SHIFT+C

Discourse info

Version v2.0.0.beta1 +202
Ubuntu 16.04 (64-bit)
Docker CE 17.12 (overlayfs2)
Bytemark Cloud VPS

What should happen

Discourse should not capture CTRL+C.

What currently happens

Discourse interprets CTRL+C as C.

Steps to replicate

  1. Press CTRL+C (or CMD+C for Mac?);
  2. Observe New Topic composer appears.

(Joffrey Jaffeux) #2

Im not familiar with the shortcut codepath, but reading the commit I see C and not shift+c, do you think this is the cause @riking ?


(Kane York) #3

Oh, yeah probably. I guess I wasn’t looking too closely at the requirements for the shortcut names…


(Sam Saffron) #4

I am not having an easy time reproducing this, what browser is this on, seems to work as desired on Chrome to me.


(Luke S) #5

Windows 10, Firefox Quantum (57.0.4) ,Ctrl + C copies to clipboard as expected. C opens the composer. Shift + C does nothing.


(Jonathon) #6

I’m hitting it with Linux 64-bit Firefox Nightly 59a1 (2018-01-21). One other person has reported the same with Firefox 57.0.4 (which triggered this report in the first place).

It does the same thing for me here on meta.discourse.org so it’s not specific to our instance, though I’ll admit it might be a browser quirk. However, the fact I encountered the same behaviour around the same time as another user makes me suspicious.

I’ll roll through some more browsers/settings tomorrow; with fresh profiles neither Chromium (63.0.3239.132) nor Firefox (57.0.4) exhibit the same behaviour for me.

Edit:

Little update: it does appear to be a browser setting. Nightly 2018-01-21 and a clean profile doesn’t exhibit the issue, but a -safe-mode start (no extensions) with my normal profile does.


(Sam Saffron) #7

Yeah we are going to need a repro here, without it we are just guessing.


(Jonathon) #8

This appears to be a quirk in some profile setting and Firefox Nightly (~2018-01-21/22). Using the same profile in 57.0.4 doesn’t exhibit the same issue.

I can’t see which setting would make this happen so it may well just be a Nightly quirk; the other user who had the issue no longer does with Firefox Nightly, so who knows…

Apologies for the noise… :persevere:


Edit, someone else just started having the issue with 59b2 (Developer). No idea what’s going on here. I’ll post back here if I can find some sort of pattern to it.


Edit, it’s a Firefox thing. I’ve just seen the same behaviour on GitHub, so “something” is sending the wrong keystrokes to the page.


(Joshua Rosenfeld) #9

This topic was automatically closed after 30 hours. New replies are no longer allowed.