Custom Layouts Plugin

Did you solve it?

Same here

@haffax7 Are you on the latest versions of the Custom Layouts and Layouts Topic List Plugins? Check /admin/upgrade

Guess overflow:hidden will be a good idea, and maybe consider to remove all HTML-elements.

Example with both things present:

Handling of fx ' and other things could also be a good idea :slight_smile:

BUT, with that said:
Thanks for the fixes! :slight_smile:

1 Like

I set like this.
Is there anything I need to do in addition?
Thanks

32_4

Did you enable the plugin in settings?

AND: Note that Custom Layouts only make it possible to use layout/widget-plugins, so you actually need another plugin for fx topic-list, custom html and so on.

Enter settings:
image

For the right sidebar, you need to define where it’s enabled, fx. latest or enabled it globally (2). You’ll also need to enable layouts overall. (1)

++ each layout/widget should have a position defined within the custom “Layouts”-tab in the Admin-panel.

This was a fast one… Hope it make a bit of sense :slight_smile:

4 Likes

AND: Note that Custom Layouts only make it possible to use layout/widget-plugins, so you actually need another plugin for fx topic-list, custom html and so on.

Thanks :grin:

1 Like

@angus, I’ve opened a PR with a tailored version of @vinothkannans fix as this plugin is also presently breaking the host site. I’ve tested it successfully on two of my sites but please review.

NB Couldn’t assign you as reviewer on Github for this plugin.

1 Like

Is this a fix for this plugin? Cause when I try to use it, this happens:

No this fix prevents your entire site from breaking as the plugin was no longer compatible with the core build on tests-passed. Similar to Topic List Previews

What widgets do you have installed? The plugin only provides a framework and you need to add other ‘widgets’ for it to actually do anything. See the OP.

1 Like

This is what I have installed. Yet, nothing shows on the plugins list.
The last one I installed was the layouts plugin (I downloaded the modules first on accident, but they still loaded and I could see the plugin list)

If the Layouts plugin was correctly installed you’d also see a Layouts route top right in Admin.

I’d check two places:

  • /logs
  • Javascript console (F12 -> Console on Chrome)

Do you see any errors?

Thanks @merefield. Fix merged :+1:

2 Likes

Any idea why the layouts work perfectly fine in one subcategory:

but not in another?

1 Like

It’s the tags and specifically this line:

You can either reduce the number of tags or try this:

.topic-list-item .discourse-tags {
   display:  unset;
}

That will cause them to wrap, hopefully.

(NB inline-block also works but unset works even better in this case)

2 Likes

Thank you so much! That works.

1 Like

Thanks for nice work.
but
When i tick: Enable right sidebar globally to yes or no there is no timeline on the topic. It is a bug or no ?? (im testing the material theme)

There will be another reason why you’re not seeing the timeline. Please try using the plugin by itself with other plugins and themes disabled.

My Sandbox has this plugin installed, has enable right sidebar globally turned off and you can still see topic timelines, e.g. Test event for bug(?) - Events - Angus' Sandbox

Also make sure you haven’t included “topic” in the layouts sidebar right enabled setting.

2 Likes

So much functionality has been provided (you people are great) that it has become rather tough to understand all the options which cross depend on each other (layout vs location plugins) for a power user (but not powerful tech) like me.

But I understand that I shouldn’t bite more than I can chew. But again, can’t help myself when see something new and useful.

1 Like

I agree! I’m going to be updating the first post of this plugin topic, and my other plugin topics soon with a standardised template that makes it easier to understand the functionality and how to implement it on your site.

If you have any specific use cases in mind for this plugin let me know and I can help you out.

1 Like

EDIT:

Let’s not talk about why it’s fixed, or not…

Sorry :wink: :slight_smile: (Missed that option)

1 Like