Layouts Plugin

I’ve made some updates to the layouts plugin and the layouts-topic-list that will fix the issue you’re seeing and also allow you to show a bookmark list.

The layouts-topic-list widget is now a general purpose topic list widget that lets you display multiple topic lists, set using the site setting layouts topic lists.




You can see it in action on my sandbox here:

1 Like

@angus I believe there may have been a bug introduced in the re-factor, as my custom html side-bar disappeared.

I’ve submitted a small PR to hopefully resolve:

Brilliant - thanks! But, i’ve a problem here…

The topic-list is enabled:

A few is added:

And layouts sidebar is enabled at the frontpage:

But nothing shows up:

Am i missing something, or could this be a bug? The topic list was disabled in the Layout-settings for a short amount of time. (layouts enabled is also ticked, ofc.)

Yes, did you read my post? :wink:

1 Like

No words from my end…

FML :slight_smile: Thanks.

1 Like

Hopefully my PR will fix it. Sort of glad it wasn’t just me as it confirms the issue and the fact I wasn’t going crazy :slight_smile:


@merefield @exetico Thanks guys, the issue should be resolved now:

1 Like

Yep, confirming your updates work fine for my instances, thanks!

Did you solve it?

Same here

@haffax7 Are you on the latest versions of the Custom Layouts and Layouts Topic List Plugins? Check /admin/upgrade

Guess overflow:hidden will be a good idea, and maybe consider to remove all HTML-elements.

Example with both things present:

Handling of fx ' and other things could also be a good idea :slight_smile:

BUT, with that said:
Thanks for the fixes! :slight_smile:

1 Like

I set like this.
Is there anything I need to do in addition?


Did you enable the plugin in settings?

AND: Note that Custom Layouts only make it possible to use layout/widget-plugins, so you actually need another plugin for fx topic-list, custom html and so on.

Enter settings:

For the right sidebar, you need to define where it’s enabled, fx. latest or enabled it globally (2). You’ll also need to enable layouts overall. (1)

++ each layout/widget should have a position defined within the custom “Layouts”-tab in the Admin-panel.

This was a fast one… Hope it make a bit of sense :slight_smile:


AND: Note that Custom Layouts only make it possible to use layout/widget-plugins, so you actually need another plugin for fx topic-list, custom html and so on.

Thanks :grin:

1 Like

@angus, I’ve opened a PR with a tailored version of @vinothkannans fix as this plugin is also presently breaking the host site. I’ve tested it successfully on two of my sites but please review.

NB Couldn’t assign you as reviewer on Github for this plugin.

1 Like

Is this a fix for this plugin? Cause when I try to use it, this happens:

No this fix prevents your entire site from breaking as the plugin was no longer compatible with the core build on tests-passed. Similar to Topic List Previews

What widgets do you have installed? The plugin only provides a framework and you need to add other ‘widgets’ for it to actually do anything. See the OP.

1 Like

This is what I have installed. Yet, nothing shows on the plugins list.
The last one I installed was the layouts plugin (I downloaded the modules first on accident, but they still loaded and I could see the plugin list)

If the Layouts plugin was correctly installed you’d also see a Layouts route top right in Admin.

I’d check two places:

  • /logs
  • Javascript console (F12 -> Console on Chrome)

Do you see any errors?

1 Like

Thanks @merefield. Fix merged :+1: