Daily perf reports asking to rebuild container on new install


(Lee_Ars) #1

After migrating Discourse to a new phy host and restoring the site from backup, I’m still getting the same error message in the staff category with the performance report option enabled—

Report is only available in latest image, please run:

cd /var/discourse
./launcher rebuild app

I went back and tried to re-do some of the troubleshooting @sam suggested in this eariler thread, but there doesn’t appear to be a /var/www/discourse/script/nginx_analyze.rb anymore, so I’m not sure exactly where to start.

I can trigger Jobs::DailyPerformanceReport from the sidekiq scheduler and it runs without errors, though it completes in 3ms and creates no topics. Triggering the report from the rails console also results in no output:

# rails c
[1] pry(main)> Jobs:: DailyPerformanceReport.new.execute(nil)
=> nil

No errors are logged in logster for either.

@downey or anyone else on the team, do you have any suggestions? Happy to do whatever it takes to get this resolved. Can also try to arrange a time to grant login access to the web host if you’d like to poke further.


(Rafael dos Santos Silva) #2

From the host run:

./launcher enter app
cat /VERSION

So we are sure you are on 1.3.7.


(Lee_Ars) #3

That’s affirmative—cat /VERSION shows:

root@dockmaster-app:~# cat /VERSION
1.3.7

(Sam Saffron) #4

@tgxworld can give you a hand debugging, he moved it to a plugin so the instructions for debugging need to be updated.

My best guess is that there is some funky security going on.


(Alan Tan) #5

@Lee_Ars

Try to trigger the script manually and see if there are any errors :slight_smile:

./launcher enter app
cd /var/www/discourse
ruby plugins/discourse-nginx-performance-report/script/nginx_analyze.rb --limit 1440

(Lee_Ars) #6

Thanks, @tgxworld. Triggering manually results in the report running without issue in the terminal window.