Different browsers different logo behaviour?

Hi guys.

I have set up a logo, in ‘logo’ & ‘logo small’ and I see those logos in Chrome(and derivatives) buf Firefox does not show it, shows 'title" instead? (which “title” in not shown in Chrome(s)).

ver. 59dd20c415

Is there something we users can do to standardize/unify this mis-behavior?

1 Like

hmmm i cannot seem to reproduce this. :thinking:

i have three simultaneous browsers (chrome, firefox and safari) on both my forum and Meta and i am getting all logos on both my ipad and windows laptop. just to make sure i updated my firefox and chrome just now too.

can you post a screenshot? have you tried firefox private browsing mode?

1 Like

I should have mentioned OS which must play its part in it - latest Fedora.

1 Like

It may help to identify the site on which you see this behaviour?

If you really don’t want to do so, you can start a trial on our hosting and configure it in the same manner and see if the problem recurs.


A few moments later… :slight_smile:
So, anybody here on Fedora (or any Linux) ?
Yes, I to think it should be easily reproducible - even easier without setting any trial.
Just do what I’m doing - grab that version, deploy - chromium based browsers show the logo, Firefox shows the title but no logo.

p.s. site is a private one & on the inside, a test lab.

1 Like

i’m running a local dev Discourse instance on an Ubuntu workstation and all logos seem to work as expected. :woman_shrugging:t2:

Do you see this on discussion.fedoraproject.org?

1 Like

It shows okey there.
I am not a webdev so I can only do diff of html source taken off both browsers and I see this:

-> $ diff brave firefox

and visually - both for the snapshot & for html source, no user is logged in

discourse logo browsers

Perhaps it’s only that specific release/version I run… or Firefox “digestion & rendering” of the code?
3.0.5 / 461966e028

I suspect your Firefox cannot handle the image type used for the logo and is falling back to text.

1 Like

But why would that only be the logo — I tried .png & .gif — and it works a ok in other places of the discourse/forum?

Ok, here is a “fix” - for me that is, it fixed the issue - even with https set & used at web server end only when I enabled ‘force https’ in Discourse, the logo appeared in Firefox (while Chrome family of browsers did not need that option enabled)

p.s ‘force https’ also affects favicon, my other topic.

1 Like

This is expected:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.