Digital Ocean forum locked in read only mode after upgrade this morning

Can someone offer some urgent help/illumination? We’ve tried just about everything, including rebuilding, but the forum remains in read only mode. The upgrade completed successfully about an hour ago. I’m working with @vinothkannans to try and repair it but so far no luck.

I already tried in command line too. Above commands running successfully and disabling read-only mode for few seconds. After that it again going back to read-only mode

Any other ideas, @vinothkannans? If I knew this could happen, I never would’ve upgraded.

No. It will not happen frequently. I did upgrade many times and I didn’t faced any issues like this. It’s strange. I think somehow upgrade is broken

Actually, this is purely a guess, but when when this happened to me, it was because I used the “Read Only Mode” button on the Admin > Backups area. That button actually did nothing, and has since been fixed. When the fix was applied, it put the Discourse instance into Read Only mode. I had to go back to Admin > Backups to disable Read Only mode.


Thanks for the suggestion @cpradio, I tried disabling that this morning but it said I can’t make changes during read only mode.

Sorry @cpradio, that WAS the fix, I was in Settings>Backup but just found the setting you mentioned under Admin>Backup. Thanks so much!

1 Like

No. Same thing is happening. It keeps reverting back to read only mode.

Okay, if it is kicking itself into read-only mode, then something else is going on. Are you running low on Disk Space?

Wow great :ok_hand:. Since am unable to login as admin I didn’t tried it myself. But why am unable to override this action in console mode :confused:. Anyway thanks @cpradio

I ran through the same sequence again, also disabled read only during backups, and reloaded all instances (I have a desktop logged in as a user and my phone is logged in under an admin account) So far, it’s sticking.

Thanks @cpradio and @vinothkannans!


Probably because your command would have to be a bit different than the post you linked to.

You would have had to run (I think)

Discourse.disable_readonly_mode(user_enabled: true)

That is correct :slight_smile: I introduced the user_enabled option which will add a non expiring key into Redis instead of an expiring key which is kept alive by a thread that renews it every 30 seconds. However, the downside is that the key will expire once we do a rebuild.