Digital Ocean, G Suite, SendGrid, Namecheap


(James) #1

I am having quite the time getting email to work with my new Discourse server.

I am using DigitalOcean to host. There doesn’t seem to be any problem there. The server is running and I’m able to log in.

I am using G Suite as my admin email, but not handling site email.

I am using Namecheap for DNS/regristrar

I am using SendGrid as the SMTP provider for the site. I’ve tried every possible combination of verification I can think of, using the top-level-doman, using the subdomain, removing the domain names SendGrid-provided DNS information to input into Namecheap, adding the domain to a whitelist G-suite (is this even necessary)?

I can get emails to send out. I can see from SendGrid that test emails were sent out from Discourse but they never get delivered. The following information is shown on the error message on SendGrid:

Received by gmail-smtp-in.l.google.com

Blocked

The gmail server blocked this message from being delivered. While we won’t try to send this message again, we will attempt to send new messages to this address in the future.

You can view all addresses in your [Blocks]
Full response from the gmail server:

550 5.7.1 Unauthenticated email from do.c is not accepted due to domain’s DMARC 5.7.1 policy. Please contact the administrator of do.c domain if this was 5.7.1 a legitimate mail. Please visit 5.7.1 to learn about the 5.7.1 DMARC initiative. m55-v6si4266550qtc.214 - gsmtp

Does this narrow down my problem strictly to SendGrid and domain verification or is it something else? Either way, SendGrid never wants to verify once I’ve pasted the information they’ve provided into my Namecheap DNS section.


(Bhanu Sharma) #2

As it says, Your dmarc record is not correct.
You can find the correct dmarc value in sendgrid and that should be updated into your dns.
Please correct it or contact sendgrid for assistance.

Just by chance, is it a one-click install app from DO?


(James) #3

@itsbhanusharma, yes. I did the one-click Discourse setup. Everything went very smoothly up until the SMTP setup. I’ve put in a ticket with SendGrid and am waiting for their response.


(Bhanu Sharma) #4

What is the notification email in your discourse admin? I think that needs to be corrected.


(James) #5

It is currently set at noreply@unconfigured.discourse.org.

When going through the setup wizard I chose for the system to handle mail so the one G Suite account I have to accompany the site info@mydomain.com is not flooded with messages, if I’m even understanding it correctly.


(Bhanu Sharma) #6

It can’t be @unconfigured.discourse.org in any case.

Please change it to @(your-discourse-domain) or the domain that’s verified with sparkpost first. I hope that’ll fix it.

Also, you may have to tweak your smtp port as DO may be blocking common SMTP ports on your account.


(James) #7

@itsbhanusharma, I made your suggested changes and it worked, although the message did go to my spam folder and is still showing “via SendGrid”. I’m guessing the way to solve that is through domain verification with SendGrid and that will be between me and them.


(Bhanu Sharma) #8

Exactly. They should have provided you some DNS records to create. Those records take care of the whole verification process.


(James) #9

Great. Thanks so much for the help. Now I’m wondering if I need to go back and undo some of the things I did like whitelisting my G Suite account with SendGrid and stuff like that.


(Bhanu Sharma) #10

Not immediately, first step that I’d take is to make sure sendgrid is happy with my domain and then I’d test the quality of emails sent using mail-tester.com or similar service.

Once that’s all fixed then only I’d lax any whitelist


(James) #11

As it’s set up now, while going through all the various forums trying to troubleshoot my problem I followed one tutorial that had me go into my G Suite settings and whitelist Digital Ocean, not SendGrid like I said. Because that wasn’t related to my actual problem is it necessary anymore or could it cause any problems in the future?

It actually wasn’t even whitelisting. It was SMTP relay service where I added my droplet IP address.


(Bhanu Sharma) #12

While it won’t really cause any problems as long as you retain the IP it can possibly cause spam whitelist if you leave the IP and other owner is a notorious spammer.

So it’s okay to remove it. Also, DO is not sending emails from it’s own IP either. Those are sent from sendgrid.


(James) #13

Great. Thanks again for the help.


(James) #14

While I’m able to get emails delivered to people who register for the forum now (albeit in their spam folder), I now am having trouble sending admin emails. When I attempt to make a member of the forum and admin, I get the message saying to check my email. My single G suite email address is info@mydomain.com. SendGrid can never seem to send a message from info@mydomain.com to info@mydomain.com. This is quite a problem because I can’t make anyone else an admin because I can never finish the process. There error I get from SendGrid is:

The mydomain.com server blocked this message from being delivered. While we won’t try to send this message again, we will attempt to send new messages to this address in the future.

You can view all addresses in your Blocks suppression group. Learn more.

Full response from the mydomain.com server:

error dialing remote address: dial tcp 167.89.106.64:0->162.255.119.167:25: i/o timeout


(Jay Pfaffman) #15

You should check the mail debugging document. The problem is between sendgrid and your mail server that is refusing connections from sendgrid.


(James) #16

I’m using Namecheap, so I had set up all of my SendGrid information CNAME records, but in the “Mail Settings” portion of the Advanced DNS page I didn’t have anything selected. Once I selected Gmail everything began to work. I swear I’d thought I had read something about if you’re setting up SendGrid you don’t need anything the Mail Settings section. Things appear to be working now.


(system) #17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.