DigtalOcean one-click install doesn't finish

I used this droplet template https://marketplace.digitalocean.com/apps/discourse which seems to run the installer as soon as you ssh into the machine. I was able to configure the install with my domain and email settings and it seems like most of the install completes. At the end, it hangs on Redis is now ready to exit, bye bye... and then I get a broken pipe error. Anyone have advice?

1 Like

Please see Discourse official Standard Installation. I recommend that you delete that droplet and start again.

But have you looked to see if discourse is running by pointing a web browser at it?

1 Like

I just created another droplet following the official instructions and I’m not sure where it ended up, somehow getting this ‘broken pipe’ thing again. I think sometimes it randomly hangs and you need to try it multiple times to keep advancing:

I’m getting Safari can't connect to the server or This site can't be reached in Chrome. ping is getting a response from the correct IP address so I think the app is just not running.

1 Like

I also tried running discourse-doctor and it seems to try rebuilding as the app is not running. For whatever reason the install doesn’t seem to finish.

1 Like

Screenshot from 2021-05-07 22-23-28

I see your SSH connection was disconnect from server that obvious interrupt the installation progress, so you need to make sure your SSH connection not broken before install complete.

You can simply try the screen tool.


Ok, I tried screen on macos and but seems to have the same result. I’m not sure why the SSH connection would break as I’m not touching the terminal.

I’ve also found some possible solutions to the ‘broken pipe’ problem that configure ssh to keep the connection alive but it doesn’t change the result for me: all installs fail to complete because of this and so the app doesn’t start. I have tried a few droplets now with 1gb and 2gb of RAM. Not sure how I can solve this or why it’s happening. Anyone experience this before?

1 Like

You can using screen -r to resume the last session after be disconnect then reconnect to the server, that’s why i recommend the screen tool, please read detail the article what I link above. The installation will keep going if you start in a screen session, so just resume it in your next connect if the connection be break.


@mrus@merveilles.town suggested

maybe their installation does a network restart or something odd, even though that shouldn’t impact the SSH connection. Try using their web console and see how far you get there maybe?

Using the DigitalOcean web console solved my problem. I think my internet connection is not great and it causes problems generally with ssh, nothing to do with DigitalOcean or Discourse.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.