Installation issues on Scaleway


(Alex) #1

Hello,

I tried to install discourse on x64 Scaleway server.
I changed settings to allow smtp according to this post ScaleWay review?

I followed instructions from this page discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub

after typing ./discourse-setup
the setup tools stop giving me infos… after this message:

INFO – : > cd /var/www/discourse && su discourse -c ‘bundle install --deployment --verbose --without test --without development’

due to : “packet_write_wait: Connection to 212.xx.xxx.45 port 22: Broken pipe”

I tried two different servers (see image below), trying Ubuntu Xenial and Debian Streched… which are up to date before installation…

I don’t really know what to do ?
Any ideas ?

Thanks


(Daniela) #2

Did you use the discourse imagehub on scaleway?


(Alex) #3

No, I didn’t… looking at github, It looks like the files are 2 years old… no update.
I started from a fresh install of Debian / Ubuntu (1 tries on each system)… following the steps of the how-to


(Alex) #4

Problem solved. It was an ssh problem.
Look at https://christophegx.ovh/connexion-ssh-write-failed-broken-pipe/
and don’t forget to restart SSH service, connect and disconnect SSH before retry !