Getting stuck during bootstrap


Can you please help me identify the problem when I install discourse?

I get stuck in this portion cd /var/www/discourse && su discourse -c ‘bundle install --deployment --verbose --without
test --without development’


This takes Quiet a While … for me, initially it took over 30 minutes so it’s probably worth waiting.


I am using smartty to connect to my droplet as I am a windows user. I am waiting for the bootstrap to finish but the software disconnects before I get to finish the installation.

try mtputty and please let me know what is Your base OS?

even if it disconnects, you should let it complete in the background and wait about 45 minutes before accessing your main website!

if you have a recently failed build maybe post some error logs to help identify the reason for disconnection?


I am using ubuntu 16.04 LTS for my discourse installation. I was wondering if discourse would continue the installation even if ssh got disconnected.

I’ll try to find some error logs and post it here.

Thanks again :slight_smile:

I have tried to use putty and the installation is not pushing through. Thanks for the help :slight_smile:

if You want, I can prepare a Digitalocean Node for You with a working discourse installation and then transfer it to your account.

let me know just in case you are stuck and need some help.

If you’re using DO, perhaps try the Console VNC access method from the DO website.


But I’m using Linode for discourse. I just got it installed and will now register for the admin account. :slight_smile:

1 Like

That could be an option but it’s not reliable in all cases and as per my own install experience, DO may disconnect due to some random timeout but it works in the backend just fine.

1 Like


I got it installed. Now the next thing is I am not receiving any email from the discourse installation to complete the admin account registration.

Did You configure some external SMTP Provider?

e.g. mailgun or Amazon SES?

can you confirm if they’re working fine?

That’s very kind of you :slight_smile:

I just wanted to try and install it my self. I want to learn something new…

I have tried zohomail if you’re familiar? Does it work with discourse?

Sure thing, Learning curve is there and there was a day when I too learned by struggling with it for over 4 days…

Sounds really interesting. I’d love to learn in the hard way.

Yes I’m familiar but unfortunately, it’s probably the worst available option for you as they have very poor limits on SMTP.

I’d highly recommend AmazonSES as they’re quiet reliable but if you’re looking for a rapid solution, go for Mailgun without even thinking!

Goodluck man!

I’d be around just in case you’re stuck!

Nevermind, You can bypass the admin creation and mark admin account as active using a command, I can link the command if you want to bypass the email verification but I’d suggest configuring forum with proper SMTP as eventually all your users will need it!

I am installing discourse for the very first time :slight_smile: I’m sorry for all the questions. For the time being if I could get zohomail to run with discourse, would be perfectly fine as I am not needing that much SMTP limitations for now.