Disable Avatar education message when `allow_uploaded_avatars` is disabled


(Florian Bender) #1

On my install, I disabled allow_uploaded_avatars since I built an SSO solution for an existing CMS installation (using Contao) and plan to use the already-available avatars from the website (not available yet). Thus users will never be able to upload profile pictures through Discourse.

However, the Avatar education message appeared recently which confused users. It should not appear when allow_uploaded_avatars is disabled, and while we’re at it, this should also be true when sso_overrides_avatar is set.

Related to: Setting to disable avatar education message


(Jeff Atwood) #2

Good point, if avatars are overridden then we should skip this education panel. @techapj can you add that to your list?


(Rafael dos Santos Silva) #3

Possible duplicate of:


(Arpit Jalan) #4

Fixed via:


(Arpit Jalan) #5