Disable load times shown at left margin of screen


(AP) #1

I’m running the docker install, imported a vbulletin database and finally got everything working. Unfortunately, the load times info still show up at the left-hand side of the screen. Is there a setting in the database that allows me to disable this?


#2

You can remove your account’s login email as one of the “DISCOURSE_DEVELOPER_EMAILS” in the app.yml

DISCOURSE_DEVELOPER_EMAILS: 'name@example.com'

Or, add the following:

DISCOURSE_LOAD_MINI_PROFILER: false

And then run:

 ./launcher rebuild app

Also:


(Khoa Nguyen) #3

Only you, the developers can see that infomation.


(AP) #4

Thanks, didn’t realize!


(David Hagar) #5

I know this is an old thread, but I tried the Alt-P option as well as adding the line to my app.yml file:
DISCOURSE_ENABLE_MINI_PROFILER: FALSE

Neither worked, I’m glad to know my users cannot see it, but somehow it honestly bugs me to have it up there when I’m logged in. There any other options for how to disable this?


(Jeff Atwood) #6

This does seem to have regressed @sam.


(Sam Saffron) #7

No, but the setting is called DISCOURSE_LOAD_MINI_PROFILER not DISCOURSE_ENABLE_MINI_PROFILER


(Jeff Atwood) #8

Alt+P is not working to remove timings any more, just tested on discourse.codinghorror and confirmed.


(Sam Saffron) #9

I need to test if this is a breakage in mini profiler or discourse. I bet our keyboard thing is not floating up the event.


(David Hagar) #10

Thank you very, very much!


(John M Harris, Jr ) #11

I know I’m resurrecting a dead thread here, but I’m having this exact issue (Alt+P not working)


(Jeff Atwood) #12

ALT+P hasn’t worked for a while now cc @sam