Disc too full without much data in the forum

Hello. I’m constantly getting low free space issue with my forum that has only 3 users and barely any files uploaded.

I’ve run the cleanup and docker cleanup but as you can see we have only 190mb of backups and 27mb of uploads. The disc in use 18GB. How can we be taking up so much space? It causes upgrades to not run and doesn’t make sense.

Self-hosted on GCP with Ubuntu 1804 Bionic OS.

Any thoughts on how to control the system from bloating or possible over-caching issues filling up our install?

Screen Shot 2021-01-20 at 3.55.08 PM Screen Shot 2021-01-20 at 3.51.15 PM

1 Like

You can use ./launcher cleaup to reclaim disk space from old docker images.


Tried it and got 0 space reclaimed. So frustrating

1 Like

I see some snaps, is this ubuntu server ?

1 Like

yes Ubuntu.

What are “snaps” I’m unfamiliar.

1 Like

You have only 18GB of disk (that’s /dev/sda1 that’s mounted at /) and you currently have 7.2GB free. 11GB in use:


That’s how much space the OS and docker and Discourse takes. You’ll need to do a ./launcher cleanup every time you do a rebuild.


Thanks Jay. I have tried all of the above and when I run cleanup I get 0mb recovered. Further the error during rebuild app says I have less than 5GB of space which also wasn’t accurate.

I had to run a bunch of Linux cleanup commands to recover space “apt-get” commands then I was able to run the launcher rebuild.

I’m guessing this has more to do with my Unbuntu version and health than discourse directly.

Appreciate all the feedback.


Digital Ocean’s 1GB droplet has 25GB of disk, which is usually enough not to cause immediate problems for a small forum. But even then it’s easy to fill the disk with a few backups.

1 Like

We are a micro forum for in house use only. 27mb of uploads and only 198mb of backups. 18GB disc shoudl be more than engough but the Linux setup was filling up. I can increase the disc size all though it’s not trivial on Google Cloud as I’ve had to do this before.

We have another forum with far more data and users on a smaller disc that is running just fine. Something got wonky on this install/virtual machine.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.