Discobot says "Sorry, I couldn’t find the link in your reply!" when oneboxing is disabled

Now:

Seems to be a newish issue since it was working fine a few months ago, when link previews were already turned off.

This was on https://forum.inaturalist.org/

Before:

1 Like

I just tested this on https://try.discourse.org/ and the link step worked correctly for me.

What setting are you using to disable oneboxes?

1 Like

I’m not staff/admin there, so I’m not sure. I’ll try troubleshooting the issue more with them.

I just tried and can reproduce this on https://try.discourse.org/. Has also been happening on a Discourse forum I moderate.

5 Likes

Shouldn’t we be able to reproduce this @Simon_Cossar if others can on try?

3 Likes

I have tested this on https://try.discourse.org/, both with the desktop Chrome browser, and with Chrome on Android. The link step is working for me without any problems. What browser are you using when it fails for you on try.discourse.org?

3 Likes

Not working for me, but not sure if I am doing something wrong

Maybe I understood the reason. It seems to be working on meta.discourse.org, but fails on forum.inaturalist.org. You might want to verify this.

Likely a broken install then? Unless we can repro it here or on try it is not a bug in Discourse.

1 Like

let me know if I can help any way :slight_smile:

1 Like

I’m an admin for forum.inaturalist.org and can replicate the issue on both Firefox 71.0 and Chrome 79.0. Here are our onebox settings:

When I change 0 to 1, the tutorial works, so I’m guessing it has to do with the onebox being set to 0.

4 Likes

Oh can that happen when the version updates? As I had said above, it used to work great on this install.

thanks

1 Like

Yes, that totally has to do with onebox being set to 0

I can repro it on my sandbox with that setting.

4 Likes

So turn off the disabling of one boxes?

1 Like

But maybe if some community doesn’t like oneboxes, can the onebox tutorial be skipped entirely?

I guess it can be done using the ‘skip’ keyword or by editing the tutorial … Am I correct?

4 Likes

That would be great, I’d prefer to not have oneboxes on our forum.

1 Like

Ok so the to-do here is to skip this step if oneboxes are set to zero per the above site setting @techapj.

7 Likes