Discobot didn't recognize link in tutorial

I was going through the Discobot tutorial on the Gitcoin forum. It made me copy/paste a link out of three. Did that, Discourse expanded the link, but Discobot didn’t recognize the link. I was on the desktop:

When I tried to flag that Discobot message to a moderator as Something else, with the message Discobot bug, I got another incorrect error:

Sorry, you can’t include links in your posts.

1 Like

This sounds like they’ve upped the trust level for min trust to post links, but haven’t tuned discobot to their custom setup. I’ve just had a test run-through on my test site and Discobot appreciated the coconut link I oneboxed for him, so they may also have tweaked something for the oneboxes on that site as well?

Have you contacted the admin there to raise these quirks?

I had the same issue on another site. I can replicate it here and at try. The problem only occurs if I only paste the link into the reply to discobot. Adding a line of text above resolves the problem and discobot detects the link.

Link to my conversation with discobot

https://meta.discourse.org/t/235575

1 Like

I’ve just had another go, and this time Discobot did not like my coconut link. :thinking:

Let’s slide this over to #bug

1 Like

I had another thought as I was confused why it worked on my first run-through and then didn’t on the lastest from today, so I spun up a brand new site as I think I used a fresh one the last time round - and this time discobot did appreciate my coconut link. :tada: :slight_smile:

I then belatedly remembered that safe mode existed…

And I tried it on my original test site with safe mode enabled, and requested a new tutorial, and this time he also liked my onebox as well. :tada: :slightly_smiling_face:

So I’m guessing it must be a conflict with a plugin or theme component. I do have quite a few of the official ones so it may be easier to look through the ones on the other site. I’ll keep digging. :+1:


Update: No, now it just seems to work every time no matter what. :thinking: @Moin, can you give me a specific set of repro steps where it consistently doesn’t work for you?

1 Like

I think I can repro it. It seems to Discobot only have problem with new links. So if you try with the same link again, Discobot can recognize. :slightly_smiling_face:

1 Like

It has worked first time for me a few times. On the fresh new site it just worked. :man_shrugging: And I’ve just signed up to try.discourse.org and it worked there too:

I’ve tried ctrl+v as well as right-click paste, but I can’t replicate it again after the one from this morning on any site I’ve tried. I’m not sure what I’m missing? If anyone can help me flesh out a step-by-step I would be most grateful. :slight_smile:

2 Likes

That would explain why it worked when I tried after @JammyDodger asked for steps. I also tried at try a lot of times today. Since the default language is english, I always tried with the english links. Now I changed the interface language to german. And Antiwitz – Wikipedia and Exotische Kurzhaarkatze – Wikipedia both were not detected.
@JammyDodger you could try a different language. In german you start the tutorial with @discobot starte tutorial. I will not use the other two german links for testing at try.

I don’t think it’s important but I use my android smartphone with chrome for testing

2 Likes

Yes, you’re right. :slightly_smiling_face: Really strange… It is just seems but yeah I think the new links partly cause it. My old android phone tricked me. :smiley: It is probably cause by timing while Discobot reply. Sometimes links need longer time to be oneboxed. Discobot reply is maybe sometimes too fast in this case and can’t find onebox. Cached and most of links works great because these are almost immediately oneboxed but which for example contains image might take longer time.

I can replicate it on try.discourse.org too with other link which contains image.
I posted it before the link is oneboxed on composer preview side.

3 Likes

I tried with the German locale, but that worked first time too. :man_shrugging: I think @dodesz’s idea is looking promising though. :slight_smile:

I will pick this up again tomorrow and see if it can be consistently repro’d. Thanks very much to both of you for your efforts so far. :+1:

2 Likes

Thanks @JammyDodger, I have they same problem as well. They do seem to be sticking, but none of these are being accepted as the correct replies.



I’m having the same behaviour too.

Just to check, do your custom links generate a onebox? If not then I don’t think they’ll be suitable for swopping in.

I hit this with extra frequency during a test run on another site and used @moin’s workaround to get past it. I still have no definitive repro steps though, so no further insight.

As a more ‘built in’ workaround you could include a similar blurb to the quote stage where you ask the user to include some text above the attempted onebox? It’s not ideal though.

2 Likes

Thanks, yes they should generate a onebox. They are all direct links back to our discourse content, so they should all be eligible.

Edit: Following up here again @JammyDodger, these are links to discourse for our own website so they should generate a onebox.

Is there a another required place for the admin to paste the links that should be accepted as answers or this should work altogether? (e.g. Listing the links & answers).

Thanks,

1 Like