Discobot tutorial gets stuck if 'something else' flag type is selected

Hi There,

I Apologise in Advance if this has been covered already but i need some advise from anyone as im new to the discourse platform and only use it in one place.

Basically…One of The DiscoBot’s Initial tasks when earning badges for your profile involves Flagging to the Admins/Moderators on a Forum some nasty words discobot has said…now i accidently clicked the wrong option when i flagged this task to the admins by not selecting “InAppropriate” in the flag list and selecting either abusive or something else.

Now from this point the tasks stopped over 5 days ago and the flagged tasks seems stuck…the site owners and admins are baffled as they cant see or clear this flag from there side it seems so unless they are looking in the wrong place or not im just wondering if theres any experts that can screenshot or point me in the right direction to advise them how to unflag the post so i can continue from where i left off without restarting the tasks again…oh and from the flag point one of the site admins/moderators appeared in the task thread and started communicating with me but they are just as confused how that happened.

Do they have to make me an Admin/moderator briefly for me to clear the flag myself or is there an easier route to do this.

Any help would be greatful.



This has come up before: Discobot flag step requires any flag except "Something Else".

The issue only seems to occur if the ‘Something Else’ flag type is chosen in the tutorial’s flag step. I previously suggested that the issue could be fixed by the user who was taking the tutorial entering the following text in a post: @discobot resume tutorial. When I test this on my site now, it is not causing the tutorial to be resumed.

The fix that is working for me is to flag a different discobot post in the tutorial as ‘inappropriate’. For example:

When I test this on my site, it causes the tutorial to be resumed.

This is probably something that should be fixed in the Discourse code. Maybe if the ‘Something Else’ flag type is selected, discobot could reply asking the user to flag another of their posts as inappropriate.


Hiya @simon

Thanks for directing my Bug post onto this thread,having now read all the posts i’ll give your suggestion ago and feed it back to the company using the discourse problem…to be fair though i put this topic in the “bugs” section because for me i see it as just that and im surprised that none of the experts creating this platform have proprrly addressed/fixed it in over 2 years all i see is moans from the team…for them it should be an easy fix or at least a way to briefly 'grey out" any other option on the 'flag inapproriate content" task in the tutorial only as this is the first point of call for users when they sign up as a “new user” so if mistakes are made there should be a way forum owners can fix this easily.

However I did find the flagged message in my “sent” folder under the envelope/message icon and it said to flag it there as well to staff to arrange deletion which i have done this evening before posting on here to see if that works as well.

Finally i will try your “Temp Fix” on their forum and see if it continues the tutorial within the 10 minutes or so timeframe…but i still think it needs addressing in the code and rolled out as a patch to all users like the other posters here have mentioned as i think its going to crop up a lot i think for there users as there forum grows so i’ll have to bookmark this post/info for reference.

Thanks Again !!!


Sorry, I wasn’t paying attention. I think this qualifies as a bug - especially because it affects users who probably don’t have much experience with Discourse. I’ll move the related posts back to the #bug category now.


@simon please dont think i was being awkward with that quote…theres many a time where i put things in the wrong section on a forum and i get shouted at first time round…reddit for example is a nightmare to understand if you dont have patience and time to explore the site settings of something new…i do appreciate you putting me into that thread as it was a very informative read. :smiley:


oh btw…i went over to the other forum and tried your suggestion with discobot and he basically just ignored the commands and replied with “Hi ! use the display help command” to which i tried this and he ignored that command as well…Grrr i think he needs a firmware update on a ThumbStick shoved right up his USB Port…putting it technically politely.

Did you try going back to the tutorial and then flagging one of the discobot's posts as “inappropriate”? You’ll have to flag a different post than the post you have already flagged. This should work to resume the tutorial. Let me know if it does not work.


yes i did try that…but no response from discobot maybe hes timed out.

I think you can reply skip to the message that is “stuck”

1 Like

Hiya @Benjamin_D

Discobot did give me the option to skip the step at the time but it seems he doesnt want to answer nowadays like he’s timed out
after 5+ days…i know i can restart the tutorial but that seems pointless when this one is still active.

I have tried so many things now its driving me bonkers,but at least we know it is a bug in the code

Kind Regards


Are we Any Further Forward To A Solution to this Issue ??? @codinghorror or @simon

I have created a fix for this so that discobot checks for the correct flag type. If the incorrect flag is used, it will reply letting the user know they didn’t quite do it right and it will remove the bad flag so that the user can try again.

Here is a demo of how it behaves now: