Discourse Event plugin timezones are still messed up

When I set the Timezone appropriately in the Event Settings as per this:

image

  1. The correct time is displayed in the Topic list (it was 2 hours ago)

  2. UTC is shown in the topic instead (i.e. 13 hours behind for us)

Workaround

At the moment, if I simply set the timezone as UTC it works fine.

I have added this CSS to prevent users from adding a timezone

// hide the timezone field for Discourse Events / Calendar Plugin
.discourse-post-event-builder-modal .timezone {
       display: none;
}
6 Likes

This is happening to me too, if there are any fixes available or if I missed a server setting I would love to know. Thank you!

2 Likes

We’re aware of the issue, and hope to have a fix ready soon. In the meantime, the workaround is to set the event’s timezone in UTC - it will then be correctly translated to everyone’s local timezone in the UI.

2 Likes

Thanks for the response, I plan to keep it set so I’ll know when its fixed. We’re still evaluating it as a way to organize events, so it was more inconvenient than game-breaking.

1 Like

I’ll be sure to post here as soon as it’s fixed - set this topic to ‘watching’ and then you’ll get a notification for replies :bell:

2 Likes

I’ve pushed a number of fixes to the plugin, so things should be working much better now :crossed_fingers:

Please let us know if you’re still seeing any timezone-related issues. (cc @nathankershaw @MrScopi)

4 Likes

This topic was automatically closed after 12 days. New replies are no longer allowed.