Discourse + Facebook Pages integration with Zapier not working

Sorry if the category is wrong, Composer is not allowing me to select categories


Hello everyone :smiley:!

I was seeing several posts about automation through Zapier, I was curious and wanted to enter to try :zap:

I have a Facebook Page, so I wanted to do this:

When I make a post on Facebook Page -> Create a post on Discourse :discourse:


I configured correctly with the data that Zapier asks me (Api Key, Api Username and Site URL), however it returns an error 403 :confused:

I have seen some CORS related errors here in Meta, but they involve a change in app.yml
I am a client of Discourse for Open Source, therefore I am not sure of my possibilities

2 Likes

Are you following what you read on this post Using the Zapier Discourse Zap Templates? If so, maybe the discourse zap hasn’t been updated yet to reflect the new API method? Just a guess.

1 Like

When you configured the Discourse account on Zapier, did you use an All Users Api Key, or a single user API Key?

I have not tried creating a Discourse post from a Facebook post, but I have tested creating a Discourse post from a WordPress post. That is working correctly for me, so it looks like Zapier have correctly updated their Discourse app to use our new API authentication method.

3 Likes

I tried both, I even tried testing PostWoman, returning the same error

#Off-Topic: Is there a way that my “title” is not automatically changed to “customer” here in meta?

If you are getting a 403 response when using the All Users API Key with both Zapier and PostWoman, it seems likely that the issue is that either the API Key or the API Username you are using are not correct. If you go to the My Apps section of Zapier and click the Test button, do you see a Success message?

If you are getting that error with a single user API Key, then the issue could be that the user you are posting as does not have permission to create a topic in your chosen category.

Another possible cause of the problem could be that the values you are sending to Discourse with the request are not valid. Are you able to create a topic through the Discourse UI with the title and the post content that you are sending from Zapier?

3 Likes

Turns out this was the problem :open_mouth:

Although it seems a bit strange to me since I had allowed that group to publish in this category (I created a user called FacebookBot and I made it a moderator), but for some reason Discourse :discourse: sometimes does not save the settings :thinking:


I created a group called “CommunityBots”, I gave permission to publish and now it worked correctly :smiley:


Thanks to @simon and @tobiaseigen for the kind attention :hugs:

I hope to have more problems very soon (Just kidding hahaha) :joy:

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.