403 error when connecting Zapier to Discourse


I am the admin of community.pynk.io and today i was assigned the task of connecting Discourse and Twitter using Zapier. I followed all steps but it happens that once i’ve filled all the fields(on Zapier side) to connect to my Discourse instance(hosted with you guys!) it throws an 403 error:

“authentication failed: Error code 403: Yu are not permitted to view the requested resource. The API username or key in invalid”

…that’s the error.

I’ve created an API key with user level=All Users and have choosen a couple of scopes to limit some things.

On Zapier side i’ve correctly typed the host url(https://community.pynk.io) and the API key i created before besides i 've used my own account on forum(admin privileges of course) but still no success after all.

The strange thing is that other two admins from our forum have tried to connect Zapier with Discourse(allow Zapier to acces our accounts on Discourse forum) and the same error is thrown…i am based in Cuba but those guys are based in England and Scotland, so i guess it is not a problem of blocking some IP’s or something like that.

Any help would be appreciated, @Falco, @simon ?


What are the scopes that you set on the key? If possible, could you try creating a new API Key that allows all actions to see if that allows you to connect to Discourse?


Is there a general problem with your site at present?

All I see is a blank page and a bunch of 404’s in the console:

Your location shouldn’t be a factor, as wherever you access Zapier from the connection is direct between the Zapier servers and your Discourse instance.

I would initially suggest opening up the key scope to be sure that it’s not a configuration issue on your part.

Incidentally, please don’t tag people in support topics, the free assistance provided here is on a best-effort basis.

1 Like

These are the selected scopes:

will try to createa new API key allowing all actions…will let you know.


Got it!

Will do that right now to test.

Sorry for that, will not do it again :pray: Just thought that tagging other people involved in similar previous topics dealing with Zapier and Discourse would bring me some kind of attention…faster.

Btw…on my end everything is ok with my forum. It is loading ok, faster and with no problem.


It might, but maybe not for the right reasons.

The sure-fire way of getting assistance whenever you need is to become a customer!

I am a customer.

I followed all steps but it happens that once i’ve filled all the fields(on Zapier side) to connect to my Discourse instance(hosted with you guys!) it throws an 403 error:
:point_up_2: :point_up_2: :point_up_2: :point_up_2: :point_up_2:

…my company pay Discourse on a monthly basis, so i guess i am a customer after all. But not need to ask some privileges because support here is good enough for customers and other people too.

1 Like

Feel free to contact our private support system at any time. It would be great to confirm the scopes that are required for the Zapier API key though, so this is a useful public discussion.


Ok…just created a new API key…selected “Global Key (allows all actions)” …tested on Zapier and nothing… now it does not do nothing, no 403 error but it is not doing nothing at all :slight_smile:

The orange button “Yes, Continue” on Zapier…i click that button and nothing, nada…

It’s been a few weeks since I last tried connecting a new Discourse account to Zapier. It is possible that something has changed that is causing an error. I’ll try connecting my account again later today and post here with what I find.

1 Like

Thank you very much my friend! Just to let you know…we have another API key working but for Favro access to our Discourse instance…and it is working fine. :slight_smile:

What should happen on success is that the modal window that you added the API credentials to closes.
After that, you can continue making the Zap.

I’ve just tested this with an All Users API key that was set to have a global scope and it worked without any problems.

When I try to set specific scopes on the All Users API key, it fails with the error message: authentication failed: Error code 403: You are not permitted to view the requested resource. The API username or key is invalid. This happens even if I select all available scopes for the API key.

The only API key that I can get to connect to Zapier is an All Users API key that has a global scope:

I just checked your site to see if I could reproduce the errors that Stephen found earlier today. Those 404 errors should not have been occurring. I am not sure what was causing the errors, but the site’s assets are loading correctly for me now with no errors. Get in touch with us if you notice any issues like that on your site.


Thank you! Just tested now and it is working as expected. This morning i was using Firefox and although i choose All Users with Global Key configuration it was not working at all…now i am using Chrome and it is working with this given configuration.

The funny thing is that all the connections i created before now are shown in main My Apps panel at Zapier…do not know…maybe was a browser compatibilty problem but the truth is that not allowing to choose a given scope is not a big problem but i guess that if Discourse give us this possibility then it should be fixed somehow.

Thank again and sorry for tagging you earlier this morning. :pray: :+1:

1 Like

Thank for this one too. And do not worry everything is working fine till now. :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.