Discourse Gifs component

Just letting everyone know that if you revert this whole commit, the icon gets back in place in the editor.

I now wonder why no more people report this bug and why isn’t it being reproduced here at meta?

We’re going to update to v2.8.3 +2 this week and I will double check if it’s compatible with current state of GitHub - discourse/discourse-gifs repository

1 Like

Unfortunately, the issue is not resolved in 2.8.3 too.

1 Like

Have you tried deleting the component and adding it again? maybe the old icon name is stuck somewhere. That commit you previously mentioned reverting only changed the name of the included icon, so it shouldn’t be something that relies on a certain Discourse version.

2 Likes

I just tried your advice, and that’s what I got at component page in admin (there was no such error before that):

Error with icons-sprite: #<TypeError: no implicit conversion of nil into String>

Screenshot

I took a note of this error, and proceeded to save my API key and no, it doesn’t fix the issue with composer icon.

1 Like

Are we the only one running into this problem? Anyone? For the past week, there were many changes introduced to main repo of this component by Discourse devs, but none of those solve the problems of:

  • Missing GIF icon in composer
  • Error of “Error with icons-sprite: #<TypeError: no implicit conversion of nil into String>”
2 Likes

We use S3 storage if it matters at all…

1 Like

We actually see this error on the DiscoTOC component page as well:


The logs are saying:

DiscoTOC theme contains a corrupt svg upload : OpenURI::HTTPError : 403 Error

We tried by de-install & re-install it. Could it be a “simple” permission error on the server only?

1 Like

Hey @Jonathan_Poyer,

Were you able to resolve the issue by yourself? Why do you think the issue is related to filesystem permissions on the server?

1 Like

The logs seemed to point towards the upload.
We have since updated some chmod and updated to latest and it was magically solved!

2 Likes

For those willing to choose Tenor and don’t already have a (v1) key, the component won’t work as it uses the first version of the API, which is legacy. Delivered keys are now v2 and the endpoints have changed :

2 Likes

Tenor support was added by @merefield. Are you planning on updating it for 2.0?

2 Likes

Hi Falco, I’m not sure whether you mean Robert or me :sweat_smile: , as it makes a lot more sense Robert, I’m for sure not planning it (probably out of my depth to do it cleanly, but hey, I could try!)

2 Likes

This is a better link to describe the changes: How to migrate from Tenor's V1 API  |  Google Developers

I’m afraid I am on deadline for a project atm but happy to look at this soon if it remains outstanding.

3 Likes