Discourse integration issues (Zapier, WP, RSS...)

Hi all,

I’ve been running a Discourse forum on DigitalOcean for a handful of weeks now, and for the most part, it’s been smooth sailing and a wonderful experience.

As of this week, though, a handful of strange issues have arisen that seem like they have to be related:

  1. The Zapier automations I set up related to Discourse are occasionally resulting in this error: “Discourse: Trigger partner failure: request to https://community.androidintel.net/posts failed, reason: certificate has expired” (But, curiously enough, they do still seem to be executing fine.)
  2. My WordPress-Discourse connection is no longer functioning. The WP Discourse plugin says “You are not connected to Discourse. If you are setting up the plugin, this notice should go away after completing the form on this page.” — and all forms of integration within WP are offline and unavailable.
  3. An API-requiring integration I have with Discourse RSS is failing to function, despite the RSS file itself being perfectly fine and available and everything with the API key itself seeming to be fine as well.

I checked the actual certificate on the site, and it seems to be okay:

My integration with Memberful, which I use for SSO (as it’s a private forum connected to a membership community), still seems to be functioning normally. And I can’t think of anything obvious that would have changed with the site configuration or anything related to it that might have prompted this.

I’m officially flummoxed. Any ideas or suggestions?

Thanks a million for the help.

1 Like

Have you tried rebuilding the app ?

These problems all sound like they could be caused by the recent changes to Let’s Encrypt certificates. To get things working again, you’ll need to update the software on any clients which are having problems. More details from LetsEncrypt here:

For things like Zapier, you will need to get in touch with them directly. They may already aware of the issue, since it is so widespread.

2 Likes

Interesting — thanks, @david. That certainly makes sense and also seems to line up more or less exactly with the timing on all of this.

I wonder if the WP Discourse plugin is having widespread issues with connections? It doesn’t seem to have any pending updates available as of this morning. And if that is indeed the cause (which seems logical), surely I wouldn’t be the only one experiencing it. I don’t seem to see any other posts about that here, though, curiously enough.

I’ll check in with Zapier on it now, meanwhile. In hindsight, I received the Zapier errors early on — in the morning hours of 9/30 (the same day that certificate change took place) — but then the integration continued to function after. So perhaps they already discovered the issue and addressed it sometime that morning.

The RSS feed is an interesting one. The feed itself still loads fine, with the API key passed along as a variable in the URL. But the plugin I’m using within WordPress to pull and display the most recent item from it keeps generating that “RSS ERROR – No RSS items found” message when accessing it. You’d think the fact that the feed itself is loading would be all that’d matter in that situation, but surely there must be some sort of connection to that and this certificate stuff. I’m just not entirely certain if it’d be on the end of the plugin, which is really just reading the (valid and accessible) RSS file, or if it could somehow be on the Discourse side with the way the API-requiring feed is being generated.

I haven’t. I’ll keep that in mind as an option, if necessary, though it sure seems like @david’s theory might explain all of this.

I’m not too familiar with the Wordpress ecosystem, but I doubt the plugins or Wordpress itself will need to be updated to fix the problem.

The root certificates are normally part of the operating system, or maybe part of the client software (in this case, PHP). If you run your own server, you might be able to run these kinds of updates yourself. If not, you’ll need to speak to whoever runs your Wordpress hosting.

2 Likes

Excellent point. Thanks again.

And an update on the RSS front, for interest’s sake: As an experiment, I tried creating a Feedburner feed from the API-associated Discourse feed, just to see if eliminating the API variable from the URL would make any difference with its processing. And sure enough, that version of the feed works fine with the WP plugin I’m using to access it. Sure seems to suggest that the issue was indeed with the plugin and its ability to interact with an API-involving feed following the certificate change.

Really appreciate all of the thoughtful pointers on this. I think I’m on the right path now to getting all of these lovely new quirks stamped out and solved!

1 Like