Discourse Integration Nextcloud bad csrf

Hi there,

I am trying to get the Dashboard integration running in our Nextcloud (22.2.3)
We used to have a discourse instance running on discourse.group where the connection worked fine.

Since we moved our discourse instance to self hosted, it does not work anymore.
Now discourse is running on a hetzner server in a Docker container. Nothing else running on that server. The DNS is configured with an A-Record.
For installation, i followed this guide: https://linoxide.com/install-discourse-docker-container/

I have found a description of a solution. But don’t know what steps to do.
Does anyone know how to solve that issue in my setup?

Are you using Google Chrome? Chrome 97 introduced a bug which broke DiscourseConnect SSO logins


We’ve added a workaround for the issue in the latest version of Discourse, so make sure you’re up-to-date. (our hosted discourse.group sites are up-to-date, so maybe that’s why things were working there)

1 Like

On my Desktop I tried the setup with Mozilla Firefox running on windows 8. Also tried with updated Brave on my Android 11.
From my perspective nothing changed on the client side.

I see that content:

With Brave, nothing happens when I click “Genehmigen”
With Mozilla Firefox I get this window
So both lead nowhere.

With Brave on Android 11 I get the Bad CSRF Error

1 Like