Discourse missing images after upgrade

We use Terraform to stand up 2 EC2 instances that we run Discourse on behind a load balancer. We recently updated Discourse with 3 years worth of updates, and finally have it up, the nfs volume is mounted, and everything is present except we’re missing most uploaded images.

I tried
./launcher enter app
rake posts:missing_uploads
rake uploads:missing
rails c > SiteSetting.migrate_to_new_scheme=true

I also tried rake recover from tombstone & rake recover from indexes, neither seems to have done anything to help.

Output of rake uploads:missing is

...
134 of 143 uploads are missing
...
1265 of 1265 optimized_images are missing

Output of rake posts:missing_uploads is

"Looking for missing uploads on: default

0 post uploads are missing."

What can I do to further troubleshoot this issue? Any idea where the uploads may have gone?

Was able to find that the images were mounted to the instance, but the volume they were in wasn’t mounted to the container. I copied them from the fs to the container and reran migrations. Now it’s working.

1 Like