Images disappeared; nothing helps - container rebuilding, uploads:recover, and posts:rebake

Logo, avatars, and post images all disappeared.

I checked the uploads folder for one of the images - they are not there.

What might have happened, and any chance to recover?

I tried:

./launcher enter app
rake uploads:recover
rake posts:rebake

as well as rebuilding Docker image with ./launcher rebuild app.

Also, tried rake posts:missing_uploads and it output 0 post uploads are missing..

1 Like

Did you migrate from hosting without downloading your images? Where do the broken images point to?

1 Like

No migration. Images just disappeared one day.

One thing is that might or might not be important is that I attached a block storage when setting up Discourse, and mapped directories in app.yml like this:

- volume:
    host: /mnt/blockstorage/shared/standalone
    guest: /shared

Then it worked just fine for ~2-3 months or so. Then one day images just disappeared without me doing anything (except maybe rebuilding in order to update Discourse to the latest version).

1 Like

Sounds like you lost your block storage somehow.

Does the block storage still exist? Do you see files in /mnt/blockstorage/shared/standalone?


The block storage does exist, and I can find NEW images in there β€” the ones I uploaded recently.

but the old ones are missing?

And there is nothing in tombstone?



Not sure what is tombstone and how/where I check it?

1 Like

It’s under uploads somewhere. You might try

  find /path/to/images -name filename-of-some-image.jpg

to look for a missing image.

There is also a

  rake uploads:recover_from_tombstone

(If I remember and type correctly)