Discourse only loads header on first visit, have to refresh to get the full application to load

Afternoon all, been stuck on this for a few days. My wack-a-mole approach is not working and haven’t been able to find a post on meta that directly addresses this problem. If I’m missing it, please share the link.

At any rate, has anyone had issues with Discourse only loading the header on mobile devices? I’ve tried turning off mobile layouts, setting “Latest” for the default view and a laundry list of other things.

Here’s a quick look at the issue.

Can you reproduce in Safe Mode ?

It looks like you have a broken theme customization.

2 Likes

Let me give it a shot.

Can’t reproduce in safe mode because when you go to safe mode it immediately refreshes the app and loads the home screen properly.

That’s because

So you should fix that.

3 Likes

Hi @pfaffman, still working on this. Just went through all of my overridden settings and reset any that might be problematic with no luck. Checked all of my plugins to ensure none are broken. No problems there.

          - git clone https://github.com/discourse/discourse-oauth2-basic.git
          - git clone https://github.com/discourse/discourse-patreon.git
          - git clone https://github.com/discourse/discourse-plugin-linkedin-auth.git
          - git clone https://github.com/discourse/discourse-plugin-office365-auth.git
          - git clone https://github.com/discourse/discourse-policy.git
          - git clone https://github.com/discourse/discourse-push-notifications.git
          - git clone https://github.com/discourse/discourse-saved-searches.git
          - git clone https://github.com/discourse/discourse-solved.git
          - git clone https://github.com/discourse/discourse-spoiler-alert.git
          - git clone https://github.com/discourse/discourse-staff-notes.git
          - git clone https://github.com/discourse/discourse-tooltips.git
          - git clone https://github.com/discourse/discourse-voting.git
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discoursehosting/discourse-sitemap.git
          - git clone https://github.com/angusmcleod/discourse-quick-messages.git
          - git clone https://github.com/angusmcleod/discourse-locations.git
          - git clone https://github.com/angusmcleod/discourse-question-answer.git
          - git clone https://github.com/angusmcleod/discourse-ratings.git
          - git clone https://github.com/angusmcleod/discourse-topic-previews.git
          - git clone https://github.com/angusmcleod/discourse-layouts
          - git clone https://github.com/procourse/discourse-full-screen-videos-plugin.git
          - git clone https://github.com/procourse/procourse-static-pages.git
          - git clone https://github.com/featheredtoast/discourse-pwned-passwords.git
          - git clone https://github.com/iunctis/discourse-formatting-toolbar.git
          - git clone https://github.com/jannolii/discourse-topic-trade-buttons.git
          - git clone https://github.com/jgujgu/discourse-blocks.git
          - git clone https://github.com/LeoDavidson/discourse-reset-bump.git
          - git clone https://github.com/rux-pizza/discourse-awesome-bbcodes.git
          - git clone https://github.com/sekhat/discourse-yuml.git
          - git clone https://github.com/synweap15/discourse-voice-record.git
          - git clone https://github.com/unfoldingWord-dev/discourse-mermaid.git
          - git clone https://github.com/jomaxro/discourse-plugin-site-setting-override.git
          - git clone https://github.com/discourse/discourse-data-explorer.git
          - git clone https://github.com/cpradio/discourse-plugin-replygif.git
          - git clone https://github.com/merefield/discourse-onebox-assistant.git

Since that’s the case, I ran an audit in Chrome and got these results. Do you see any good clues here?

Tried removing all my custom css. I got nothing. :neutral_face:

Open browser developer tools and check the Console tab for any warnings or errors there.

1 Like

All 200 with no errors in Console. Recently discovered lots of the same problem showing up in the site log… now just have to learn how to read this much javascript.

As @falco and @pfaffman mentioned earlier, you have a broken theme or theme customization. There’s a syntax error somewhere in your theme javascripts. You may need to remove any theme components or custom themes installed one at a time to figure out where the issue is.

3 Likes

There it is. Easy Footer component was the culprit this whole time. Grrrr. haha

Thanks y’all!!

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.