Forum stuck on the loading home screen

Hello i’m trying to open my forum and its stuck on loading screen

i tried to open it from another device , same problem !

what should i do ?

Most of the time this will be caused by something custom, like a theme component.

Try safe mode to do some debugging:

More info:

same problem

but the site still working on my browser i guess it cached !

When a Discourse forum isn’t working, sometimes you can still browse the cached version.

Did you try rebuilding your app to fix the issue? Is it a standard install?

i got these problems IDK if it the cause the problem or not.

ok i will try to rebuild the app now.

i tried to rebuild the app and same problem

Strange, when I use safe-mode it seems to work.


blank page :frowning:

Well, at least that’s different than a “loading home screen” :smiley:

Could you try safe mode in a different browser, in an incognito window and ideally on a different device?

1 Like

i tried to access from my browser and incognito and my mobile and my friend browser
same problem :frowning:

and this from diff OS

Very strange, I now also am not able to load things properly anymore. Network seems to hang on downloading a .js file.

I think this goes beyond my skills, so hopefully someone with more experience can chime in. In the meantime, to help these people, can you answer the following?

  1. Could you list the customizations that you’ve done?
  2. When did it last work properly?
  3. Did anything change between when it worked and when it stopped working?
  4. Do you see anything strange happening on your server/host? CPU spikes, diskspace etc.

Hope you’re able to get things back up soon!

1 Like

yep its very strange !

its was working fine before 2 hours ago !
and i was write a topic fine !
i didn’t do anything to the host,server i didn’t do anything like a customizations
if there is any LOG that’s can i access throw SSH to show it for u i will be happy

My friend sent this screen to me it could help you.

The forum is working well on my end, even without safe mode:

I’m on MacOS, using the last version of Arc (Chromium-based).

Also on Chrome Android:

Maybe there are some temporary network issues on your server?


Same for me now, it loads just fine


now it’s back to work fine after many rebuilding app

IDK what was the problem
if there is any LOG to show you ?

1 Like

I’m not an expert in sysadmin stuff, unfortunately. I guess I’d look at Nginx logs… But the fact that it stopped working and worked again without any action from you suggests even more of a temporary network issue, in my opinion.