Discourse Reply via Email NEVER works


(Tim) #1

I’ve setup and changed the admin - email settings dozens of ways - nothing works!
I’ve tried replying to posts via e-mail with outlook Office 365 & gmail accounts

The replies via e-mail to go to like replies+aaskdf92r89qfhaw92@gmail.com never make it anywhere.
Replies to address like cci.replies+20938973498430843@gmail.com fail too

However, replies sent to a specific email like xyz@gmail.com that are defined for specific categories DO create new posts in the appropriate category. What am I missing?


(Felix Freiberger) #2

Does anything interesting show up in /logs?
If you manually log in to the Gmail account, do the mails (still) show up there?


(Tim) #3

The logs will consistently show errors if the email discourse polls is setup like
me.replies@gmail.com vs. me@gmail.com

I had everything working except reply via e-mail and now I’m seeing not even e-mails sent to e-mail addresses specified under a category aren’t posting now either.

I’ve changed these settings so many times back and forth and sent e-mail replies but any e-mail sent from a gmail or Office 365 account to anything but replies+208938932982398@gmail.com (just an example) will return non deliverable immediately EVERY time.


(Wes Osborn) #4

Just to confirm a few things:

  • Are you using a public gmail account or a google for domain/business account ?
  • I believe you need to do something special to setup catch-all addressing on a domain/business account.
  • To confirm your usage, your “basic” gmail address is something like: username@gmail.com ?
  • Without involving Discourse at all, if you send an email to username+1234@gmail.com does that message land in the inbox for username@gmail.com ?
  • It may be helpful to temporarily turn off Discourse checking for email so that you can review all messages in your inbox before Discourse attempts to process them.
  • If the test message isn’t there then there is something wrong with your gmail setup. Make sure that you are checking your SPAM/Trash to make sure that the messages are landing there for some reason.

(Felix Freiberger) #5

Can you post a screenshot of the settings you are currently using (remember to black out sensitive data)?


(Tim) #6

I finally figured it out. Felt stupid when u did but I literally had
replies.% {replytag}@gmail.com as the pop3 polling email for reply by
email.

Changed that to a real email we owned with the .% {replytag}@domain.Com and
everything began working


(Jeff Atwood) #7