Reply By Email Configuration


(Brian Carpenter) #1

I have a working installation of Discourse setup. I have a test mailgun account setup that is working with this installation. Discourse is successfully sending out verification emails and topic replies. However I am not sure how to properly setup reply by email. For instance when I try to reply to a topic by using the “reply to this email to respond” contained in the email, I get an error message from Mailgun:

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

replies+randomcharacters@discoursedomain

What other settings do I need to make to my Discourse (or Mailgun setup) installation to allow this?

Any help is appreciated. Thanks in advance.


(Jeff Atwood) #2

Your first problem is that mailgun is for outgoing emails (exclusively? not sure), but reply-by-email is about incoming email.


(Brian Carpenter) #3

Thank you. So for Discourse to work with reply by email, you need to have access to an incoming mail server for the discourse domain name. I my own hosting servers so that would not be a problem. Where would I go to setup the incoming mail server settings?


(Jeff Atwood) #4

There is a #howto topic here on setting up reply via email, I suggest following that.


(Brian Carpenter) #5

Thank you for that. I was able to setup the POP3 polling.

Once I have pop3 polling setup I did test. My user replied to a message from a topic via email. The message was sent successfully to the mailbox and according to my server logs, the discourse server did log into the email account via pop3. The message was also removed from the server showing that the " pop3 polling delete from server" enabled setting to be working. The problem is the reply never showed up in the Discourse topic and there are no error messages that I can see.


(Brian Carpenter) #6

Ok I got this working. Here was the issue:

  1. I am using cPanel for the discourse user.
  2. cPanel supports plus addressing however it routes anything that comes after the ‘+’ sign to its own folder.
  3. The solution was to create an email filter to route any message that had a plus address in the To header to the inbox folder so the Discourse installation could find the message.