Discourse-solved broken migration

Discourse Version: 2.8.0.beta4
The recent updates (last 7 commits) broke my migrations:

/var/www/discourse/plugins/discourse-solved/plugin.rb:702:in `block in activate!': undefined method `register_topic_list_preload_user_ids' for #<Plugin::Instance:0x0000560f2d7a5318>
Did you mean?  register_topic_custom_field_type (NoMethodError)

** INCOMPATIBLE PLUGIN **

You are unable to build Discourse due to errors in the plugin at
/var/www/discourse/plugins/discourse-solved

Please try removing this plugin and rebuilding again!
173:M 30 Aug 2021 10:28:58.559 # Redis is now ready to exit, bye bye...
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 4279 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
31203867aea6de5292ee75de44e07092307e88c9046824c265fce1f1792ff077
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
==================== END REBUILD LOG ====================
Failed to rebuild app.

I can also confirm that after the latest rebuild on tests-passed + solved broke the whole site for me. I had to turn off solved for now.

Thanks for reporting the issue, I am taking a look into this now.

1 Like

@Stanzilla @zsero I confirmed this was broken on beta4 and stable, but it was working fine for me locally on tests-passed. I’ve just merged this fix to discourse-solved: FIX: Stop register_topic_list_preload_user_ids from breaking old versions by martin-brennan · Pull Request #160 �

Please try pulling down the latest changes and rebuilding.

1 Like

Thank you, I can confirm that the build no longer fails with these changes.

1 Like