Discourse to Slack (one-way) integration


#1

If I only want a one-way Discourse > Slack setup, could I just leave the “slack incoming webhook token” blank? This is how I have my settings and it doesn’t seem to be working


(David Taylor) #2

Yes, you can leave the incoming webhook token blank and it should work fine.

Have you tried the “Test Notification” button in the “Plugins”/“Slack” section of the admin panel?


#3

I just started getting pinged on slack to stop spamming #general lol…it looks like messages aren’t going to the new channel that they set up. Waiting to hear back from internal dev, but it’s probably a configuration issue on Slack.


(David Taylor) #4

The channel that you choose when setting up the “incoming webhook” on slack is not necessarily the one that discourse will send posts to. (I’m not entirely sure why Slack asks you to specify a channel, then ignores it)

To change where discourse sends the messages, you need to change the setup in the “Plugins”/“Slack” section of the discourse admin panel. Delete the existing filter (which will be sending to #general), and create a new one for the channel of your choice.