Discourse-Translator++

official
multi-lingual

(Tobias Eigen) #42

Long translations need better handling already, and we’ve discussed the idea of allowing users to improve translations. What if there were a message displayed to the user indicating a post is too long to translate automatically, and provide links to flag for manual translation and to manually translate?

This is functionality I’d be willing to contribute :money_with_wings: to help make happen.


(Alan Tan) #43

Just fixed this to work with latest. Upgrade soon :smile:


(Tobias Eigen) #44

:sunflower: thank you! upgrading now.


(Олексей же) #45

Hello. When i try to install this plugin i’ve got an error
FAILED
--------------------
RuntimeError: cd /var/www/discourse && su discourse -c ‘bundle exec rake db:migrate’ failed with return #<Process::Status: pid 18727 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn’
exec failed with the params {“cd”=>"$home", “hook”=>“bundle_exec”, “cmd”=>[“su discourse -c ‘bundle install --deployment --verbose --without test --without development’”, “su discourse -c ‘bundle exec rake db:migrate’”, “su discourse -c ‘bundle exec rake assets:precompile’”]}
b841e4ff2a3928f5e8e62a263d3508c551af2da1ccc5fe37580f9232f23240ef


(Tobias Eigen) #46

I’m not having this problem. When I upgraded all went well.


(Олексей же) #47

It’s not after update, I try to install plugin on few last version and see this error.


(Sam Saffron) #48

Need a lot more context to figure out what the error is


(Олексей же) #49

Hello. I use this instruction to install plugin Install a Plugin
When i add additional hook into app.yml and rebuild container i see error in my previous message.
Here more detailed message: [Ruby] I, [2015-12-03T07:51:53.115557 #36] INFO -- : > cd /var/www/discourse && su dis - Pastebin.com


(Alan Tan) #50

Thanks for reporting. I think I know why will have a fix coming up soon.


(Олексей же) #51

Good news, i will wait for fix.


(Alan Tan) #52

Can you try if this fixed it for you?

https://github.com/tgxworld/discourse-translator/commit/3af035a401362c8550f001517817fd7720e4d2ad

I could only reproduce the error by intentionally loading the file in the wrong order.


(Олексей же) #53

Another error, i think there is problem with method name I, [2015-12-03T11:51:47.703019 #36] INFO -- : > cd /var/www/discourse && su dis - Pastebin.com


(Alan Tan) #54

ah yes I noticed that and have already fixed it :stuck_out_tongue: just rebuild your container again :smile:


(Олексей же) #55

Cool, it’s work. But microsoft translator is not so smart as google :smiley:


(Alan Tan) #56

Google has no free tier. I’ll wait till more users request for it before I implement it :stuck_out_tongue:

Quite a number of good suggestions and feedback from @tobiaseigen I would like to implement first.


#57

Much appreciated. Definitely going to implement this in our community.


(Tobias Eigen) #58

Hey @tgxworld continuing to love this plugin of yours. Is it possible for you to make translations editable by mods? I’d love to be able to manually go in and fix small translation issues like this one.

Google’s translation is not much better but provides an edit link to improve the translation.

Less pressing but still an issue that needs to be addressed at some point is that I also still get many errors in sidekiq related to this plugin. They look like this and appear to occur every time a topic is viewed which could get expensive as our site gets more active. I think you know about this already.


List of project ideas for Google Summer of Code 2016
(Alan Tan) #59

Please upgrade :slightly_smiling:

I just fixed a pretty serious performance issue


(Tobias Eigen) #60

updated and all appears to be well. thanks! :thumbsup:

still getting the many errors in sidekiq related to translation that I have reported before, but they don’t seem to be causing any issues.


#61

I noticed recently that our instance has stopped working. Is that somehow related to the bugs you fixed @tgxworld?