Discourse-Translator++

official
multi-lingual

(Christoph) #130

Under what cirumstances will the translate icon not be shown? I understand that if the detected language corresponds with the user locale, it will not be shown. But are there any other reasons for it to be hidden?

I am trying to troubleshoot why I am not seeing the translator icon at all…


(Alan Tan) #131

Sorry for my late reply here.

The button will not be shown when

  1. The plugin is disabled
  2. When the locale selected is not support.

(Christoph) #132

So that means I should see tha translate button next to a post written in English even when my locale is English?


(Alan Tan) #133

Oops I missed out

as well.


(Christoph) #134

Is the subscription key (now labelled as “Client ID”) the Subscription ID I find here?

And the translator client secret is one of the keys shown in [my earlier post](http://translator client secret), right?

I keep getting

401: Access denied due to invalid subscription key. Make sure to provide a valid key for an active subscription.


(Alan Tan) #135

If you’ve migrated to Azure, you just need to fill in azure_subscription_key with KEY 1 in your earlier post.

translator_client_id and translator_client_secret is deprecated and will be removed from the plugin once Microsoft marketplace removes Microsoft Translator on 30th April 2017.


(Daniela) #136

PR submitted for italian translation


(Tobias Eigen) #137

Hey guys - I am a procrastinator so only getting to this now. In the conversation above I can see there’s a little confusion caused by the admin settings filter. Can you change “azure subscription key” to “translator azure key” so it also shows up when people filter by translator? I think “subscription” here may also be causing confusion because it’s not used in azure I think. It’s just called “key”.

Also, the localization is a bit screwy on my site - see screenshot. I see non-english characters.


#138

This plug in looks sick! Well done. I have may use later down the track for Mandarin and Hindi :0


(Christoph) #139

I have done that:

but I still see no trace of the plugin in the front-end. This (below) is where the globe is supposed to show up, right?


(Alan Tan) #140

What is your default locale and what is your current user locale?


(Christoph) #141

Both are usually English but I have changed my user locale to another language but it made no difference.


(Alan Tan) #142

Can you provide me with both locales? Certain locales are not supported by the translator.


(Christoph) #143

Of course: Default locale: English (en), user locale: German (de). Also tried: user locale: Swedish (sv)


(Alan Tan) #144

I’ll test it tomorrow. Azure portal is down for me right now and I can’t retrieve my keys. Btw are there any errors in your logs?


(Christoph) #145

I have no problem accessing the Azure portal at this moment.

My log has two errors for today:

Error: Nothing handled the action ‘refresh’. If you did handle the action, this error can be caused by returning true from an action handler in a controller, causing the action to bubble.

and

Discourse::InvalidAccess (Discourse::InvalidAccess)
/var/www/discourse/plugins/docker_manager/app/controllers/docker_manager/application_controller.rb:20:in `ensure_admin’

The only translations related error that I can spot is from 6 April:

NoMethodError (undefined method deep_merge!' for nil:NilClass) /var/www/discourse/vendor/bundle/ruby/2.3.0/gems/i18n-0.7.0/lib/i18n/backend/simple.rb:35:instore_translations’

BTW: there is a rendering mistake in the above quote (or at least I would expect that a quote would be reproduced exactly as i paste it). Here is source code:


(Tobias Eigen) #146

FYI - I’m having the same issue on my site. The globe language switcher is no longer showing up.

update: I just upgraded discourse to tests-passed and the language switcher is back. go figure. :slight_smile:


(Christoph) #147

What does that mean? I guess I should just upgrade to latest version (although translator never worked for me in the first place)?


(Tobias Eigen) #148

I have no idea if upgrading fixed it or simply rebuilding via the ./launcher rebuild app command. All I know is this morning I checked based on what I read in this topic and saw the globe was missing, then I upgraded and the globe was there.

tests-passed is the version used here on meta and by those foolhardy enough to be at near the bleeding edge of discourse. This is what I see on my dashboard:


(Alan Tan) #149

Hmm something is very broken on Azure portal…