Discourse upgrade failed

Hi,

Please help restore the forum https://community.oscedays.org/

I started an upgrade on April 29, first the Docker manager, which was successful, then Discourse the first module on the list, which failed after about 30%.

Here is the message I got: Error 500

"The software powering this discussion forum encountered an unexpected problem. We apologize for the inconvenience.

Detailed information about the error was logged, and an automatic notification generated. We’ll take a look at it.

No further action is necessary. However, if the error condition persists, you can provide additional detail, including steps to reproduce the error, by posting a discussion topic in the site’s feedback category."

Thank you.

You’re probably out of disk space. You might try

cd /var/discourse/shared/standalone/backups/default
ls

and then

rm some-backup-files

If this is an emergency you want to throw money at, can see Discourse Upgrade – Literate Computing, LLC or Fix Your Broken Site – Literate Computing, LLC if you wait until I leave my desk in the next half hour or so.

2 Likes

Interesting, what about this report clued you into the idea that it is a disk space problem? Not disagreeing, just curious.

2 Likes

Hmm. Maybe I’m getting those messages confused now.

Yeah. I didn’t pay enough attention to the fact that it was an unsuccessful web upgrade. I suspect that this may be some other error having to do with the failed upgrade.

And now that I see that it was a couple days ago that the problem started, I guess this isn’t an emergency. :slight_smile:

Now that I’m noticing it was a failed web upgrade, I think the solution is

cd /var/discourse
git pull; ./launcher rebuild app

As it’s displaying an oops message it’s very likely to be a broken plugin, isn’t it?

4 Likes

Thank you all for your prompt replies and advice. I have zero expertise in software, as an admin for the forum I thought that just following the instructions to upgrade will work. In any case, hopefully we’ll be able to fix this and next time I’ll know better what to do.

I asked one of our DO admins to run the launcher rebuild app (per Jay’s message). If he cannot fix it, I’ll ask for help again. In any case, I’ll let you know what worked, so it helps others.

I like your software and the whole idea of Civilized Discussion. We’ve been using it for more than 5 years with few glitches. I hope this problem can be solved fast.

1 Like