Discourse uploading errors and SSL_ERROR_BAD_CERT_DOMAIN error

Hello,
I’m having a problem with my discourse installation I’m getting a problem when uploading my logo from Firefox, and when I force reload the site I get SSL_ERROR_BAD_CERT_DOMAIN.

Message

MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-ASN.mmdb) could not be found: No such file or directory @ rb_sysopen - /var/www/discourse/vendor/data/GeoLite2-ASN.mmdb

Backtrace

/var/www/discourse/lib/discourse_ip_info.rb:81:in `rescue in mmdb_load'
/var/www/discourse/lib/discourse_ip_info.rb:77:in `mmdb_load'
/var/www/discourse/lib/discourse_ip_info.rb:15:in `open_db'
/var/www/discourse/lib/discourse_ip_info.rb:10:in `initialize'
/usr/local/lib/ruby/2.7.0/singleton.rb:125:in `new'
/usr/local/lib/ruby/2.7.0/singleton.rb:125:in `block in instance'
/usr/local/lib/ruby/2.7.0/singleton.rb:123:in `synchronize'
/usr/local/lib/ruby/2.7.0/singleton.rb:123:in `instance'
/var/www/discourse/lib/discourse_ip_info.rb:156:in `get'
/var/www/discourse/app/models/user_auth_token.rb:43:in `login_location'

The website works on Safari without problems

Please share your site domain. Those warnings are completely unrelated.

Here you go www.ludoa.ba

That domain doesn’t exist

host www.ludoa.ba
Host www.ludoa.ba not found: 3(NXDOMAIN)

I’m not quite sure what does that mean. I’ve never used cloud services before or Ruby applications. Mostly some PHP stuff. Could something with the setup be wrong?

You need to go where you bought the ludoa.ba domain and set it’s DNS. You need at least one DNS entry of the A type on the www subdomain pointing to the IP address of the server running Discourse.

3 Likes

I’ve actually done all of that…

How does it even work on Safari :laughing:
I’ve setup the domain to point to the 3 DigitalOcean servers, and also put my IP in the Zones with A type

Strangely enough. When I look up the domain on WhatsMyDNS it appears that it hasn’t propagated yet. :thinking: It worked well yesterday…

This is not a propagation issue, when the DNS servers of DigitalOcean are queried directly they also say your hostname does not exist.

It’s also not a Discourse issue - please contact DigitalOcean support about this.

; <<>> DiG 9.16.1-Ubuntu <<>> www.ludoa.ba @ns1.digitalocean.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 4644
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;www.ludoa.ba.                  IN      A

;; AUTHORITY SECTION:
ludoa.ba.               1800    IN      SOA     ns1.digitalocean.com. hostmaster.ludoa.ba. 1669066654 10800 3600 604800 1800

2 Likes

Here is the response that I’ve got…

Screenshot 2022-11-23 at 10.27.33

I also contacted my domain provider and they also said everything looks good from their point of view

So I’ve managed to connect through Chrome, but Mozilla and Safari don’t work for some reason. The new issue I’m having is that I can’t authenticate Mailjet SPF and DKIM

So I’ve put the info in the DNS Zones but still nothing happens. When I try to register, I don’t get the mail verification. I’m sure that I’ve set up everything correctly during the install

Your apex domain ludoa.ba is indeed pointing to that IP address.

But www.ludoa.ba is not.

I also do not see an SPF record for your zone. It seems to me that you need more guidance in setting up the DNS records. DigitalOcean should be able to help you with that.

1 Like

Thanks for the reply. I’m sorry that I’m a bit of a hassle.

So I followed the supported guide and when I go to mailjet and try to authenticat. It goes well but then when I input the keys nothing happens… The first time I did the install everything was okay… I will contact them, thank you again

Solved! I didn’t set the records over at DigitalOcean :rofl: THANK YOU VERY MUCH!

2 Likes