After update I still get "Your Discourse installation is out of date"


#1

After the last update, I see this:

Your Discourse installation is out of date. Click here to upgrade.
Installed Latest Version v1.9.0.beta12 +52 1.9.0.beta13 Updates are available. Please upgrade!

yet, on /admin/upgrade everything is already “Up to date”:

Repository Name Status
discourse (0a31190) Up to date
discourse-details Up to date
discourse-narrative-bot Up to date
discourse-nginx-performance-report Up to date
discourse-presence Up to date
docker_manager (7b09885) Up to date
lazyYT Up to date
poll Up to date


"click here to upgrade" not disappearing
"click here to upgrade" not disappearing
(Stefano Costa) #2

Ciao!

This can happen for many reasons but just ssh into your Discourse server and ./launcher rebuild app … there are many support topics actually.


(Stephen Chung) #3

I know it doesn’t really matter and that the system is updated.

How do I know? Because I just DID a ./launcher rebuild app and STILL it shows beta12 needs update.

So, no, I’m afraid you haven’t solved the problem.


(Andy Triboletti) #4

I have also noticed this.


(David Taylor) #5

It looks like the version bump tag was applied to a commit on master (as normal). But that commit hasn’t moved across to tests-passed yet.

Once the team fix their internal build, everything should be back to normal :slight_smile:


(Dexter MacCulin) #6

Same here,

@David_Taylor any action needed from our side ?


#7

“Me too” on this latest beta13 update. Is it because there’s also a docker update (git pull just brought some new stuff down)??

Note that in order to even start my update, I always need to put my current IPv6 address into my CloudFlare whitelist. They really seem to distrust that one-click update script for some reason.

But once it’s updated and confirmed, heading back to my Admin panel and it still says we’re out of date. Doing a rebuild after the git pull to see.

Edit: A full launcher restart after git pull didn’t help either. Something’s up with this version?


(David Taylor) #8

I don’t think so. The team don’t tend to work weekends, so I expect it’ll get fixed on their end on Monday.

I think it’s just a git tagging issue, see my post above.


#9

I thought I was getting this because I was running Ubuntu 14.04. When I went in SSH I received the docker upgrade message. I just upgraded to Ubuntu 16.04, manually upgraded Docker, rebuilt Discourse app, and still getting the message.

On the bright side, it forced me to upgrade everything to the latest versions.


(Agustín Santiago Gutiérrez) #10

Same thing here. I was afraid my “git situation” was broken or something (I had made some very minor local changes to the commits, but finally reverted everything to normal together with this update). Good to know it is not me.


(Sam Saffron) #11

@neil looks like we need to do some more bumping


#12

I just did a clean manual install of Discourse on a new DO droplet. Same issue.


(Neil Lalonde) #13

Apparently the tag didn’t take. Will have to do it later unless someone else on the team can tag it.


(David Taylor) #14

The tag is there, but the commit it’s attached to has not moved to tests-passed because the build is broken.

Release v1.9.0.beta13 · discourse/discourse · GitHub


(Jeff Atwood) #15

Ok @tgxworld can fix the build his Monday which is USA Sunday.


(Alan Tan) #16

Our build server was skipping the job to update our tests-passed branch which has now been fixed.


(Jeff Atwood) #17