Docker in VMWare - How to access to Discourse


#1

I installed and setuped Discourse with docker on Ubuntu 16.04 on VMware. But I don’t see the discourse homepage when I put my VM ip address in my browser.


(Mittineague) #2

Hi fredkgb welcome to the forum

Installing and configuration isn’t one of my strong points, but hopefully this can be of some help.

I have Windows 10
I installed VMware Player (free version not the paid)
I created an Unbuntu 16.04 LTS guest
I open the guest
fredkgb1
login
fredkgb2
Then I very carefully followed this topic


From within the guest, pointing the browser to “localhost” opens the forum
fredkgb3


#3

Thanks for you answer!

Sorry I wasnt really precise with me question. But I installed Ubuntu without GUI (command line). Now I want to access the discourse site from the main computer. Not in the VM.

I am able to do that ussually (I use a lot of VM for developping), but I think it’s the docker thing who prevent me to access Discourse.


#4

You can try some things inside the VM to figure out what works and what doesn’t

“docker ps” should give you a list of running containers like this, where the interesting part is the status, ports and bound IP address:

ssvenn@disco:~$ docker ps
CONTAINER ID        IMAGE                 COMMAND             CREATED             STATUS              PORTS                                      NAMES
a4a2d40e3539        local_discourse/app   "/sbin/boot"        3 months ago        Up 3 weeks          0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp   app

0.0.0.0 means it is bound to every IP on that server, if it only says 127.0.0.1 you are stuck connecting from localhost.
Make sure the firewall is disabled in ubuntu or configured to let http and https through, and make sure the vmware player is configured to allow outside connections (usually this means bridged networking). Double check the ip address with “ip addr” on the commandline.

You can also test typing “curl localhost” on the commandline of the ubuntu VM to see if you actually have the app running correctly and responding to requests.


#5

Thanks! Will try this :slight_smile: