Docker install on MacOS

Is it possible somehow to run working discourse on Docker in MacOS system? I have some issues with that, obtaining errors, such as:

Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
cd /pups && git pull && /pups/bin/pups --stdin
/usr/local/bin/docker: Error response from daemon: Mounts denied: for more info.
are not shared from OS X and are not known to Docker.
You can configure shared paths from Docker -> Preferences... -> File Sharing.
See https://docs.dock.
ERRO[0000] error getting events from daemon: net/http: request canceled 

It happens on ./launcher rebuild app command. Do you know what can I do to run docker container with app fully functional? Please help :slight_smile:

it seems that nobody cares about devs and ops which are using mac as their primary desktop system…

I dont use docker on my dev machine on mac. I did directly setup various components using homebrew for easier version selection and and mailcatcher. I also use puma-dev (which you can use with unicorn) to have discourse.tld support locally.

I have a few alias to start, stop, reset, swap dbs… but that’s all. Docker is overkill and will slow you down IMO.


I am a MacOs user and I had zero problems starting Discourse dev instance on my machine using Docker For Mac. I’ve cloned main repo and followed this guide:


I tried to run Discourse locally on my Mac.
But not with any luck …
(I have “masked” the data I actually used to

myserver:discourse root# ./discourse-setup
./discourse-setup: line 93: free: command not found
./discourse-setup: line 116: [: : integer expression expected
./discourse-setup: line 125: [: : integer expression expected

Ports 80 and 443 are free for use
samples/standalone.yml -> containers/app.yml
./discourse-setup: line 93: free: command not found
Found GB of memory and 8 physical CPU cores
./discourse-setup: line 197: [: : integer expression expected
./discourse-setup: line 201: [: : integer expression expected
./discourse-setup: line 205: 256 * : syntax error: operand expected (error token is " ")

Hostname for your Discourse? []:
Email address for admin account(s)? [,]:
SMTP server address? []:
SMTP port? [587]: 465
SMTP user name? []:
SMTP password? [pa$$word]: PasswordInClearText
Optional email address for setting up Let's Encrypt? (ENTER to skip) []:

Does this look right?

Hostname :
Email :
SMTP address :
SMTP port : 465
SMTP username :
SMTP password : PasswordInClearText

ENTER to continue, 'n' to try again, Ctrl+C to exit:
DISCOURSE_SMTP_PORT change failed.
web.ssl.template.yml NOT DISABLED--Are you using a non-standard template?
web.ssl.template.yml NOT DISABLED--Are you using a non-standard template?

Unfortunately, there was an error changing

-d This may happen if you have made unexpected changes.
myserver:discourse root#

I tried looking into lines 93,116 and 125 in and tried to execute the line mentioned:
and that failed with “-bash: free: command not found” - just as the error message says.

Has anyone got the docker image up and running on a Mac?

1 Like