Docker update then putty

I keep up with updates and when I did the docker today then went to do the rest I got this

image

which is new to me,

all went good with putty but wanted to post and ask, no worries?

That is necessary a couple of times a year. We also made a note about it on the latest release topic.

2 Likes

:facepalm:

which I’ve neglected to read this time

Thank you for the answer

1 Like

Sorry I got the same message (which i knew from some months ago) so no problem on this, but this time when I run:

cd /var/discourse
git pull
./launcher rebuild app

I get this Error:

So I red this thread:

(which is closed so I cant reply)

and I am referring to:

I have rebootet the server from:

  • CLI
  • ACPI-Command
  • Force Shutdown (disconnect Power)

But everytime I boot the machine back up and try to run

cd /var/discourse
git pull
./launcher rebuild app

It triggers the very same Error.
If you think I should open a new Thread for this please just move my Post into a new one. I dont want to spam the board with new threads, but apparently can not reply on the other closed Thread and its “solution” did not work for me

EDIT:

my Setup is

  • runs in Docker
  • installed like recommended
  • Debian 10 (latest)
1 Like

You have two problems, first, with Git

You are in 'detached HEAD' state. You can look around, make experimental

Somehow you have made local code changes that conflict.

xec failed with the params "socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1"

It also looks like postgres is having problems on your instance. Did you install using the standard method, the only method we support?

1 Like

Yes like stated here:

But I already managed to solve the problem.

I stopped the container and run the commands again after a reboot.
Notice that I had to turn off autostart for this container. Dunno why but then it worked.

2 Likes