Docker version not supported after the later update


(Spooky) #1

Everything worked fine until today. I Upgrade the docker via the admin page, after it finished, the forum loads fine. I went to upgrade the discourse version but I then get to a page that tell me this:

<html><head></head><body>
<h2>You are running an old version of the Discourse image.</h2>
<p>
Upgrades via the web UI are disabled until you run the latest image.
</p>
<p>
To do so log in to your server using SSH and run:
</p>

<pre>
cd /var/discourse
git pull
./launcher rebuild app
</pre>

I never had this page before. I logged in to the server via SSH and try to run those commands and I get:

Error: Docker version 1.11.2 not supported, please upgrade to at least 17.03.1, or recommended 17.06.2.

What to do? Thanks.


(cpradio) #2

I believe you just have to request docker to upgrade, easiest way (for me), was to run
wget -qO- https://get.docker.com/ | sh


ERROR: Docker version 1.9.1 not supported, please upgrade to at least 17.03.1, or recommended 17.06.2
(Spooky) #3

Worked, thanks a lot.


(Régis Hanol) #4