Don't claim support for Ruby 2.0


(Wladimir Palant) #1

Install document currently says:

Ruby 2.0+ (we recommend 2.0.0-p353 or higher)

Actually, Ruby 2.0.0 won’t work. When I tried I got an error from the Sidekiq gem:

uninitialized constant Sidekiq::Sinatra

This was coming from sidekiq.web.rb:

module Sidekiq
  class Web < Sinatra::Base
--------------^

sinatra/base is required above. While I don’t know Ruby, I guessed that this is a language incompatibility. And indeed, the error went away after switching to Ruby 2.1.2.


(Jeff Atwood) #2

I don’t know you would have to ask @sam


(Dogweather) #3

I think your request is a little over-broad. Sidekiq is tested continuously against Ruby 2.0.0. MRI 2.0 is also listed as an acceptable version in the requirements.


(Sam Saffron) #4

Discourse runs fine under Ruby 2.0, in fact our official Docker image ships with Ruby 2.0

Not sure what you are doing here to get this problem:

  1. If you are doing production discourse are you using discourse_docker ?
  2. If you are doing dev work on discourse, describe your setup.

(Wladimir Palant) #5

Interesting… I was under the impression that the Docker image used Ruby 2.1 but I see now that there are multiple images.

I am doing production Discourse but without Docker - using that with our setup is rather complicated to say the least.

The environment (Puppet-configured) was Ubuntu 12.04, Ruby 2.0.0 installed via RVM (it was 2.0.0-p645 I think), Postgresql 9.3 from apt.postgresql.org, jemalloc. The only thing I changed to make the error go away was asking RVM to install Ruby 2.1.


(Wladimir Palant) #6

I tried it again and this time Ruby 2.0.0 worked fine. No idea what when wrong the first time, never mind then.


(Sam Saffron) #7