Edit title bug while Regular badge

I have lost my Regular badge but I got it back.


In this topic it shows Edit Title button

n b

but in this it does not show

(please apologize me for writing in caps)

Is this some sort of bug related to character limit?


No error: [FREE] Device :computer: - Get device info! - Extensions - MIT App Inventor Community

Error: Help with App - Highlight and read a line / a section by using Javascript - Work for Hire - MIT App Inventor Community

Hello. :slight_smile:

Are you saying that you expect there to be a pencil icon at the end of the topic title, but it isn’t shown?

Are you able to edit the topic using the option from the post admin actions?

Screenshot 2022-07-11 at 14-02-34 Edit title bug while Regular badge - bug - Discourse Meta

1 Like

I am able to see those admin action icons :slight_smile:

I was expecting that pencil icon to arrive at the topic.

I can’t yet edit the topic (since I am only a regular)

I’m trying to follow the context here, but how can you see admin action icons if you are a regular?

Are you sure the time limit isn’t exceeded for editing your own topic as a regular user?

I believe a Regular can edit a topic title indefinitely while they remain a Regular.

There is a small delay between achieving the Regular badge and it appearing on your usercard, which would explain the first screenshot in the OP. However you get the perks straight away even if it’s not quite reflected in your usercard yet, so that shouldn’t be an issue.

Admins and Mods do have the ability to ‘edit lock’ individual posts from the post wrench, which would also block title edits if done on an OP. It pops a little padlock icon on the post, but it’s only visible to staff and the user whose post it is.

@S_B_2_Go You may need to ask the admin of that forum if there is anything special about that topic.


From what I see AppInventor Community (I recognize your Usercard from there) is in version Discourse 2.8.0.beta10, possibly updating it could be corrected? :thinking:

1 Like

It is possible that there was just a delay with updating your permissions, although as said above, the delay is normally very short although it depends on the server load and specifications. If the server is loaded it may take a bit longer for the permissions to switch over to regular.

1 Like

I’ve slid this over to #support as I’m not sure it’s a legitimate bug.

If you can replicate with some repro steps I can follow and test with we can always move it back again. :+1:


After a week it is still not showing


Odd. I’m all out of ideas. Could you try logging out and back in again?

This topic title also editable.

Only :

This specific topic title not editable

I log out and log in again but still not fixed.

Did you ask the admin if it was edit locked?

1 Like

The admins don’t like responding to their members.

but i am posting a PM to one of the admins who still respond.