Editing a table with empty headers fills them in with the default text ("Column A", "Column B"…)

i notice when i edit a table using this tool that it adds lettered headers to tables without headers - then i have to manually delete them after. for example if you use this feature to edit a GitHub repository theme table on here (they never have headers) it adds A, B, and C headers. this is unnecessary and headers should be added by the user only if they are needed. one has to go manually remove the letters from the table code after editing.


I can repro :smiley_cat:

It also duplicate the table in my case… :thinking:

Did you encounter the duplication as well @Lillinator?


i did but i thought it was me making a mistake LOL. i just repro’d that now.

Apparently, there are two distinct bugs. I tried editing the table after manually filling in the headers, but it duplicated it anyway. Looking for consistent repro (or see if there are conditions when it doesn’t repro the duplication).


i’m getting weird stuff. it reproduced the table, but then it disappeared.

on my site i can’t seem to repro the duplicate table but i definitely have the inserting header issue.

i’ve tried editing 3 different tables on Meta and the duplicate i saw briefly on one of them. very strange.

1 Like

i’m of the opinion that in addition to fixing the header insertion bug, that when we use the table builder there should be the option to delete the header row or have it empty, similar to deleting the table rows.

1 Like

Thanks @Lilly … I am putting pr-welcome on this!