Email addresses no longer visible in admin pages


(Mittineague) #1

We recently upgraded our version, and when I went to the Admin pages for some routine moderating tasks I noticed that the

email addresses are missing!

These pages could benefit from further enhancement, but without moderators being able to see an even limited number of email addresses nor able to filter accounts by them, the ability to moderate for problem accounts is severely crippled.

Please give this fix high priority.


Some Ideas for Spam Control
(Jeff Atwood) #2

Already addressed a while ago – try looking at the site settings for show email on profile


(Mittineague) #7

Yes, I saw that, but I thought that was to show or not show them on the Profile pages.

Thanks for explaining, I was in panic.

If setting that to true will show them on the Admin -> User pages then I’ll need to pester @HAWK to get them back

No reason to give SPAMmers a leg up, they cause more than enough trouble as it is.


(cpradio) #8

Okay, when I re-enable that setting, it still won’t show email address on the Admin > Users Listing Pages. It shows in the Admin User Profile and the User Profile, but I can’t do a bulk search on the User Listing pages anymore :frowning:

What I don’t know, is if that was intentional, after re-enabling the setting. We use that feature a LOT, as it is easy to identify multiple accounts, bots, etc by the patterns of their email addresses.


#9

It still doesn’t show on Admin > Users Listing Pages.
Is this an oversight or a deliberate change? If it’s the latter, we’ll sort it ourselves but it would be good to know so that we don’t waste time on it if you’re going to reinstate it (I notice that @cpradio’s post above mine was liked by someone outside of our community, so it looks like it’s not just us that are missing it).


(Kane York) #10

I’m pretty sure it was deliberate, as part of the ‘click to show email’ change.


(Tobias Eigen) #11

what is the workflow again that requires this to be visible on the users page? I don’t see the point of having it in there for my own purposes. When I need to contact users outside the forum I can always do that by exporting the user list which I do periodically anyway.


(Mittineague) #12

Please let me know where I as a moderator need to click.

I’ve looked, but if it’s there somewhere I’ve missed seeing it.

The only email address I can see anywhere is mine, and well, I already know that.


(Tobias Eigen) #13

Does your user admin page not look like this? See the “Show” link next to the Email address. Click on that to show the email address.


(Mittineague) #14

My localhost as eviltrout does.
But my SitePoint as a Moderator does not.

Perhaps your community is small enough and you are the only moderator?

Although having the capabilty on individual member Admin pages would be better than nothing, what is more devastating to being able to efficiently moderate is not having them on the Admin -> User “Active” and “New” pages.
The ability to Filter by Membername and Email address on those pages was a step in the right direction, but removing email addresses from them is crippling.


#15

[quote=“tobiaseigen, post:13, topic:21363”]
Does your user admin page not look like this?
[/quote] Yup, ours does.

[quote=“Mittineague, post:14, topic:21363”]
But my SitePoint as a Moderator does not.
[/quote] Mine does so it must be admin, not mod.

I don’t think that solves our issue though. I’ll wait on @codinghorror to confirm that it has gone for good on the userlist page before deciding how to proceed.


(Dave McClure) #16

Looks like the ability for mods to see it has some recent support:

Edit: sorry, misunderstood the discussion is now focused on whether email addresses should be shown on the User List page… so you can search / filter by it, etc.


(Kane York) #17

Identifying patterns in the emails of new accounts to proactively identify spammers.


(James Milligan) #18

Weird one here. I’ve got an unapproved user that I can’t show the email for… it has the ‘Show’ button, and ‘Not verified’ just above it. Clicking it generates a 404 when trying to ‘PUT’ to emails.json for the username. Works correctly on other users.


(Dave McClure) #19

That sounds like the issue reported here:


(Sam Saffron) #20

To me this feels a bit odd:

This “security” thing out of the box is heavily convoluting my regular work as a moderator.

cc @zogstrip @codinghorror


(cpradio) #21

It won’t even search by email for us moderators only… :frowning: (even when setting show email on profile to checked).

This has definitely cramped our moderating too.


(Sam Saffron) #22

That is an old bug, we need you upgraded to latest cc @santouras


(cpradio) #23

We are pretty close to latest… we are on a commit higher than beta6 at least (so can you elaborate on old bug?) As we used to be able to search by email address and it went away when the “show email on profile” was introduced

Happens on my Dev machine too, which is latest (when I tested it a few days ago)


(Régis Hanol) #24

Nope, right now only admin can search by email. I will allow moderators too and add the show email button.