Emoji on macOS has an extra character compared to iOS ⛳️⛳


(Matt Sephton) #1

I typed the golf flag in the subject line using macOS Cmd+Ctrl+Space shortcut to bring up the character picker.

14

Notice how the emoji has an extra unicode character square after it?

If I type the same subject line on iOS there is no extra character after the golf flag.

Thoughts?


(Sam Saffron) #2

@joffreyjaffeux can you have a quick look, only appears to repro on mac (I saw it yesterday, but did not see on Windows)


(Kris) #3

Might just be older versions of OSX? I’m on High Sierra and I see


(Joffrey Jaffeux) #4

I can’t reproduce, also on sierra.


(Joffrey Jaffeux) #5

However, I copied the end of the title string:

irb(main):005:0> "⛳️".codepoints
=> [9971, 65039]

65039 is U+FE0F VARIATION SELECTOR-16 – Codepoints which I believe shouldn’t be here.

If I copy the emoji from ⛳ Flag in Hole Emoji and add it to the end of the title, save, and then edit and copy the end of the string:

irb(main):009:0> "⛳".codepoints
=> [9971]

So far my best guess it the macOS emoji picker is doing something it shouldn’t? Can you take a screen of what you see exactly please ? I might have a mac not on sierra, will try tomorrow.

Also I found this Some emojis ending with `\ufe0f` are not completely matched · Issue #28 · mathiasbynens/emoji-regex · GitHub which tend to go in my direction


(Matt Sephton) #6

Now I’m seeing this:

I’m on High Sierra 10.13.2 (17C205) with Safari 11.0.2 (13604.4.7.1.6)

Interestingly I don’t see the block character using Chrome.


(Matt Sephton) #7

I’ve reported this bug to Apple, rdar://36800472

I does it in a blank plain text file, so it’s definitely a macOS problem.

emoji.txt (6 Bytes)

Thanks all


(Markus) #8

What should we see inside the emoji.txt ?

I have the issue with Safari too, but not with TextEdit.


(Joffrey Jaffeux) #9