Error after upgrading to Ubuntu 22.04.1 LTS

Just updated to Ubuntu 22.04.1 LTS.

Then did:

cd /var/discourse
sudo git pull
sudo ./launcher rebuild app

It worked for some minutes then failed with an error (see below).

If I now do this again:

sudo ./launcher rebuild app

I immediately get the same error again:

$ sudo ./launcher rebuild app
x86_64 arch detected.
docker: Error response from daemon: cgroups: cgroup mountpoint does not exist: unknown.
ERRO[0000] error waiting for container: context canceled
Your Docker installation is not working correctly


I followed the steps in the linked article. They ran successfully.

Unfortunately when then doing

sudo ./launcher rebuild app

again, the error occurs again.

Update 1

One suggestion was to install cgroup-tools:

sudo apt update
sudo apt -y install cgroup-tools


Unfortunately, this did not work in my scenario, even after a reboot.

Update 2

I’ve also upgraded Docker from 19.x to 20.x.

Then, after a reboot, I tried this again:

sudo ./launcher rebuild app

This time, it succeeds.

:tada: My forum now works correctly again :partying_face:


I’m making the assumption that you’ve upgraded from 20.04.x LTS.

I will be going through a test upgrade in a local VM tomorrow, I suspect the key will be to repeat Set up the repository step 3, i.e. updating /etc/apt/sources.list.d/docker.list to use jammy rather than focal, followed by apt-get update && apt-get upgrade to bring the packages up to date with the new source list.

You’ve already solved your issue but for anyone else that finds their way here, I’ll report back afterwards as to whether this works in the way I expect or what extra steps are required.


For what it’s worth, I’ve just upgraded a sandbox from 20.04 to 22.04.1, everything discourse related seems to be working, (it locked me out of the oracle instance, but that’s another story :sweat_smile: ).


I ended up actually doing it tonight. The way GPG keys were handled in 20.04 has been deprecated but it is just a case of reinstating the docker apt repository and upgrading.

So the process of upgrading an existing Discourse install on Ubuntu 20.04 to 22.04 is:

  1. Do the release upgrade in 20.04, following the standard steps
  2. Reboot the system to complete the upgrade
  3. From the Docker installation instructions, do steps 2 and 3 of Set up the repository.
  4. sudo apt-get update && sudo apt-get upgrade

What I always do is spin up a new vm and see that it works and then restore a backup there. There is no down time and no risk that something will go wrong and leave you stuck. You can even use a elastic ip (I somehow can’t remember what digital ocean calls it) and switch it over, so you don’t even have to change dns.

If I needed to keep the same physical machine, I’d probably move sites to a vm for a bit while I upgraded the machine with a clean install and then transfer over.

Otoh, I’ve seen plenty of reports of people doing its upgrades and it works just fine if you some mind the down time. But do make sure that you have a backup so you can spin up a new server should something go badly wrong.


They call it floating IPs :slight_smile:

I use a the exact same strategy for everything that’s in production but still try out the process of upgrading the OS in the sandbox to make sure I know the pain points. People do try to update OS on the same vm in production and end up breaking everything (without a backup) so it helps troubleshoot those installs.


Did anyone run into the error when trying to upgrade to 22.04?

Preparing to unpack .../docker.io_20.10.7-0ubuntu1~20.04.1_amd64.deb ...
The aufs storage-driver is no longer supported.
Please ensure that none of your containers are
using the aufs storage driver, remove the directory
/var/lib/docker/aufs and try again.

They used to, but it’s now “Reserved IP” (which IMHO is not a better name): Release Notes :: DigitalOcean Documentation

June 16

  • We have renamed the Floating IP product to Reserved IPs. The Reserved IP service retains the same functionality as the prior service.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.