Error cloning git repository, access is denied or repository is not found

I have been successfully pulling a theme from a public Github repo for the last week and suddenly today I am getting this error:

“Error cloning git repository, access is denied or repository is not found”

I deleted the theme from Discourse and tried to import anew. Same error.

I then tried to import from GitHub - discourse/discourse: A platform for community discussion. Free, open, simple. . Same error.

My Discourse is up to date.

Is this happening to anyone else? Any ideas?

1 Like

What is the url of the theme?

https://github.com/ZainoLabs/discoball

Thanks for taking a look

1 Like

That looks like your repository to your clone of discourse, not a theme. Jay was asking for the theme’s url. The contents would look something like this.

5 Likes

OK, I see my mistake now. Funny thing is that the clone was working as a theme fine for several days before it broke.

Anyway, you got me on the right path. Many thanks! :taco:

2 Likes

I hope that you’re not running that clone in production. No good can come from that.

6 Likes

I’m not. I got a new theme set up properly now.

2 Likes

Save us some pain down the line and just make sure that when you’re in /var/docker the result of git remote -v is as follows:

origin https://github.com/discourse/discourse_docker.git (fetch)
origin https://github.com/discourse/discourse_docker.git (push)

Because if there’s any chance it says https://github.com/ZainoLabs/discoball you’re going to have real problems updating in the future.

4 Likes

Yep cool. And that repo of the clone will be deleted shortly as well. Thanks for the tip.

6 Likes

I just tried to install the graceful theme using the install feature in the discourse admin and i’m getting this error. Any ideas?

The error message is almost certainly correct. Does the url you are using work in your web browser?

1 Like

Yesterday it wasn’t working. Today it is.

1 Like