Error when attempting install


#1

Hi,

Have installed Docker / Git
Cloned Image
Copied templates app.yml, redis.yml & data.yml

Then modified the app.yml file to include my postgreSQL & Redis details along with host, notifications & so on.

When I run sudo ./launcher bootstrap app

I get following error message

Status: Downloaded newer image for discourse/base:2.0.20180802
cd /pups && git pull && /pups/bin/pups --stdin
/usr/bin/docker: Error response from daemon: could not get container for data: No such container: data.
See ‘/usr/bin/docker run --help’.
cat: cids/app_bootstrap.cid: No such file or directory
“docker rm” requires at least 1 argument.
See ‘docker rm --help’.

Usage: docker rm [OPTIONS] CONTAINER [CONTAINER…]

Remove one or more containers
rm: cannot remove ‘cids/app_bootstrap.cid’: No such file or directory
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

Thanks in advance for any assistance.

Todd


#2

Is this a fresh install or an upgrade? Which installation instructions are you following?

You normally shouldn’t have to edit the .yml files for a basic install, ./discourse-setup should handle all that for you.
If there isn’t a specific need for separate containers and a more complex setup I would just follow discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub and keep it as simple as possible until you have the instance up and running.

I’m unfamiliar with the data.yml container but it’s probably meant to handle persistent storage in a fully cloud-native installation like on Kubernetes when overlayfs isn’t an option.


#3

Thanks for your response.

It’s a fresh install but I want to use my own PostgreSQL & Redis


#4

…oh wait data.yml is the postgres server container I think. It should probably be paired up with web_only.yml instead of app.yml but I would really just go with the easy single-container setup unless you have a good reason to split it up.

You probably also have to build build the redis and postgres containers before the rest, have you tried “./launcher bootstrap data” and “./launcher bootstrap redis” ?

When you say “my own” do you mean outside of docker, or just the separate containers? I don’t think providing your own postgresql and redis is officially supported, you would have to pick apart the scripts to see how the Discourse bootstrap process configures everything…


#5

Thanks again for your response,

Yes outside docker- AWS


(Bhanu Sharma) #6

There is an article about using external postgres which may fit your usecase.


#7

Thanks @itsbhanusharma Ill take a look in the morning.

Looks promising.

Cheers

Todd


#8

Thanks again @itsbhanusharma

This was exactly what I was looking for.

Only catch for me that was not documented (maybe stating the obvious) but you have to grant Can Login permission to your new Discourse user in the database.

So stoked right now.

Cheers

Todd


(system) #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.