Error when entering .tk domain

When I change the domain to speedydev.tk, it keeps showing this error:

Checking your domain name . . .
WARNING: Port 443 of computer does not appear to be accessible using hostname:  speedydev.tk.
WARNING: Connection to http://speedydev.tk (port 80) also fails.

This suggests that speedydev.tk resolves to some IP address that does not reach this
machine where you are installing discourse.

The first thing to do is confirm that speedydev.tk resolves to the IP address of this server.
You usually do this at the same place you purchased the domain.

If you are sure that the IP address resolves correctly, it could be a firewall issue.
A web search for "open ports YOUR CLOUD SERVICE" might help.

This tool is designed only for the most standard installations. If you cannot resolve
the issue above, you will need to edit containers/app.yml yourself and then type

./launcher rebuild app

But in the firewall, ports 80 and 443 are open. What do I do?

1 Like

There’s nothing specific to .tk domains here.

Have you tried following the advice?

First of all, is the server that you’re using at 158.101.14.131?

4 Likes

Yes, I’ve made it point to 158.101.14.131, which is the Public IP of the VM Discourse is hosted on.

1 Like

Did you try the next piece of advice?

If you’ve already done that, have you tried running a simple server listening on port 80 or 443 and seeing if you can connect to it from outside?

Is that IP address assigned to an interface on the VM, or is it translated by a service within Oracle Cloud? If it’s not assigned to an interface, the VM itself may not be able to talk to that IP in which case the test failed incorrectly and you can ignore it.

2 Likes

It worked perfectly fine when I used speedydev.zapto.org as the domain and I was able to connect to it with no problems, but when I changed it to speedydev.tk it no longer works.

Based on the guide for hosting Discourse on Oracle, the Public IP which I said I pointed the domain to, is the IP which is used for the forum.

1 Like

I suggest to rebuild and launch the container and then see if you can access it.

2 Likes

Ok. I’ll try that. What are the commands to do that again?

./launcher rebuild app should do so

2 Likes

Ok, thanks. Let me see if that works.

Currently, if you enter directly the IP in a browser, you get the same error. So, doesn’t seem linked to the domain (which seem to correctly point to this IP address).

A PNG to the IP doesn’t work. Seems nothing is answering at this ip right now.

1 Like

Ok, it seems like it’s only a problem with domains from Freenom. If I use domains from other places it works fine. Guess I’m back to searching for free domains.

1 Like

When I checked earlier, speedydev.tk resolved to 158.101.14.131 as it should.

Did you try leaving that configured and using it?

2 Likes

I had removed it, I’ll re-add it and see if it works.

It works now! All I had to do was wait for it to connect to the IP. Thanks for the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.