Error when starting Discourse, Redis port already in use

Alright, so a recently I got a message from my Uptime Monitor that my Discourse Forum went down. I checked what was going on. It was offline. Though the server it was running on was online. I rebuilt the app to start it again.
Then I got this error:

The only error messages I found, were following:

I don‘t have anything else running under that port though.

Can anyone help me? I do not know what I should do.

Thanks in advance.

Could anyone help me?

How was this installed?

What else is on the machine if anything?

1 Like

It was installed a while ago following the install guide. It just randomly went offline.

I run a Minecraft Server on the Server too. Though, it does not use Redis and it uses port 19132 so that should not be a problem. It has always worked with it. What I have noticed though, that if I go to the domain to my forum I get a page from nginx saying it works.


If you docker ps what do you see? What’s the output of docker info?

Which plugins do you have installed?


Sorry for the late response:

I only had one plugin installed, the Check Mark thing for support.


And if you netstat -tulpn | grep 6379 ?

1 Like

Command not found.
Do I need to run it in the discourse folder?

Is the server running ubuntu?

If so sudo apt-get install net-tools

The path you run it from isn’t important.

It‘s running debian, which is basically ubuntu… Yeah.
I‘ll install that then I will run the command.

Nothing happens